Bug 471764 - When using a twofish dm-crypt device, the module "twofish-x86_64" is not loaded, but "twofish" is.
When using a twofish dm-crypt device, the module "twofish-x86_64" is not load...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 20:05 EST by Jayson King
Modified: 2008-12-09 06:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 12:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jayson King 2008-11-15 20:05:26 EST
Description of problem:
There is an x86_64 optimized assembly module for twofish, "twofish-x86_64". But when I access a twofish dm-crypt device, the module "twofish" is loaded instead of "twofish-x86_64", even though my CPU is x86_64.

In comparison, if an AES dm-crypt device is used, the module "aes-x86_64" is loaded.


Version-Release number of selected component (if applicable):
2.6.27.5-94.fc10.x86_64


How reproducible:
Always


Steps to Reproduce:
1. use a twofish encrypted dm-crypt device
2. lsmod
3.
  

Actual results:
twofish is loaded rather than twofish-x86_64


Expected results:
twofish-x86_64 should be loaded


Additional info:
Comment 1 Dave Jones 2008-11-18 17:57:02 EST
looks like the best way to fix this is just to not build the non-x86_64 versions on 64bit kernels.  I'll make the change.
Comment 2 Jayson King 2008-11-19 01:29:17 EST
Yes, that fixes it.
Comment 3 Fedora Update System 2008-11-27 21:19:16 EST
kernel-2.6.27.7-130.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kernel-2.6.27.7-130.fc10
Comment 4 Fedora Update System 2008-12-09 06:36:45 EST
kernel-2.6.27.7-134.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.