Bug 471774 - Workflows don't allow reporter to fail/reject fixes
Workflows don't allow reporter to fail/reject fixes
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 22:40 EST by Allen Kistler
Modified: 2013-06-23 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-16 20:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen Kistler 2008-11-15 22:40:32 EST
Description of problem:
Bug 448344 on bugzilla.redhat.com is not fixed after an update, but as the reporter the only options I have for the status are to leave it as MODIFIED or change it to CLOSED.

Version-Release number of selected component (if applicable):
3.1.4+ (according to the online home page)

How reproducible:
Always

Steps to Reproduce:
1. Log in
2. Go to the bug
3. Notice that I can't change bug back to ASSIGNED

Actual results:
CLOSED is the only option to change status

Expected results:
Should be able to reject the fix after testing, if testing fails

Additional info:
Sent mail back in August as suggested (see below).  Since then the front page no longer lists RETEST as a status, but just lists MODIFIED.  Otherwise everything is the same.

Rahul Sundaram wrote:

> Allen Kistler wrote:
>
>> Is there any page or document that describes the new (RH?) Bugzilla
>> workflow states?
>>
>> For example, I reported a bug for F9. It's now in the MODIFIED state,
>> so it shows up as RETEST on my "front" page. I've retested it, but the
>> bug is still there and the only thing I can do in BZ is close it, which
>> is obviously *not* what I want to do.
>>
>> Is this a BZ bug or is there something I'm missing?
>
> Seems to be a bug. Drop a mail to mail id in the top of
> https://bugzilla.redhat.com/ with the description and the bug report
> number that shows the issue.
Comment 1 Noura El hawary 2008-11-16 20:50:46 EST
Hi Allen, Basically the current status workflow in bugzilla only allow you to change status of bug to open state, if you were the assignee , qacontact of the bug or have editbugs permissions. none of the three applies to you so that is why you can not change the bug to an open state.

Noura

Note You need to log in before you can comment on or make changes to this bug.