Bug 471778 - scim-bridge crash when converting ichioku to Kanji
scim-bridge crash when converting ichioku to Kanji
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anthy (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 00:41 EST by CHIKAMA Masaki
Modified: 2009-03-02 11:59 EST (History)
2 users (show)

See Also:
Fixed In Version: 9100h-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 11:55:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 505776 None None None Never

  None (edit)
Description CHIKAMA Masaki 2008-11-16 00:41:53 EST
Description of problem:
 The scim-bridge gets segv when conveting kanji from いちおく to 一億.

>scim-bridge[2242]: segfault at 31 ip 001a7656 sp bf9644a0 error 4 in libanthydic.so.0.1.0[1a1000+3f000]

Version-Release number of selected component (if applicable):
scim-bridge-0.4.15-8.fc9.i386
anthy-9100e-3.fc9.i386

How reproducible:
anlways

Steps to Reproduce:
1. Turn on IME 
2. input いちおく
3. hit space (convert to kanji)
  
Actual results:
 scim-bridege died

Expected results:
 get 一億

Additional info:
 The same problem reported on Debigan.
 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505776

 There is some analysis about the problem by maintainer(?). (in Japanese) 
 http://www.daionet.gr.jp/~knok/diary/?11161129
Comment 1 CHIKAMA Masaki 2008-11-16 01:27:05 EST
Removing history file of anthy (rm ~/.anthy/) , the problem disappeared.
There is some additional condition to reproduce the problem.
I'll down the severity.
Comment 2 CHIKAMA Masaki 2008-11-16 03:19:20 EST
I found a reproducable step.

1. echo 'ADD "INDEPPAIR" S"一" S"位置"' > ~/.anthy/last-record2_default.utf8
2. start new scim (or reboot system)
3. turn on IME
4. input いちおく
5. hit space (convert to kanji)
Comment 3 Akira TAGOH 2009-02-06 07:56:07 EST
I can't reproduce this issue on anthy-9100g-1.fc11 though, can you also double-check it? if it works fine, I'll plan to ship it for F-9 and F-10.
Comment 4 CHIKAMA Masaki 2009-02-08 08:28:47 EST
I rebuild anthy-9100g-2.fc11 using 'mock -r fedora-10-i386', and
I can't reproduce the comment #2 any more.
It seems that the problem has been solved on upstream.
Thanks.
Comment 5 Akira TAGOH 2009-02-10 07:27:28 EST
Thanks. anthy-9100h-1.fc9 and anthy-9100h-fc10 is in testing now.
Comment 6 Fedora Update System 2009-03-02 11:55:48 EST
anthy-9100h-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-03-02 11:59:02 EST
anthy-9100h-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.