Bug 471781 - Sound broken by system update on Nov. 15.
Sound broken by system update on Nov. 15.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 02:43 EST by Neil Forrester
Modified: 2009-07-14 10:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:13:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Forrester 2008-11-16 02:43:17 EST
Description of problem:
The automatic update system updated some things including the kernel (to 2.6.27.5-37.fc9.x86_64) on November 15, and now the sound doesn't work on my machine. Specifically, whenever I try to play anything in the normal way, it makes seemingly random clicking noises. I can write directly to /dev/audio and get the expected results, but any normal program I've tried makes just makes clicking noises. I have a Dell Precision M4300 laptop. lspci describes my sound card like this:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Some things I've already tried:
1. Booting with the previous kernel version. It doesn't work either any more, but instead of clicking noises, I get silence.
2. Headphones. The clicking noises come through them instead of the speakers.
3. Adding various lines to modprobe.conf, of the form "options snd-hda-intel" followed by various combinations of "model=dell", "model=dell-3stack", "model=dell-m43", "position_fix=1", and "position_fix=2". None of that changed anything, and I changed modprobe.conf back to it's original state, which was empty.

Nothing else that obviously related to sound was updated during the update that broke it, besides some packages associated with totem. However, I find it unlikely that totem would have broken the whole sound system.

How reproducible:
Whenever I try to make a noise by any method other than writing directly to /dev/audio.

Steps to Reproduce:
1. Fully update a computer like mine.
2. Try to play a sound without directly writing to /dev/audio.
3. Turn the volume all the way up.
4. Listen to the clicking (it may be faint, but not always).
  
Actual results:
Apparently random clicks.

Expected results:
Normal noise coming through the speakers.

Additional info:
That's about it.
Comment 1 Steven Schveighoffer 2009-05-27 16:14:39 EDT
I have the same issue, sound worked great when I first installed, but sometime in the past (I thought it was after november, but I could be wrong), sound stopped working, and I get clicks whenever I want to play sound or a video with sound.

My sound device is listed below:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

I did not notice which kernel broke it, but it was at least earlier than 2.6.27.15, because that was the earliest kernel that was left on my system, and I don't know how to download older kernels than that.

I have not tried the /dev/audio directly, not sure how to do that.
Comment 2 Jaroslav Kysela 2009-05-28 09:53:51 EDT
Does 'aplay <some_wav_file>' work on your systems?
Comment 3 Steven Schveighoffer 2009-05-28 19:48:11 EDT
(In reply to comment #2)
> Does 'aplay <some_wav_file>' work on your systems?  

No, same clicking sound heard.
Comment 4 Bug Zapper 2009-06-09 23:16:57 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Steven Schveighoffer 2009-06-10 13:02:04 EDT
Oh, didn't realize this was a F9 bug, I was having the issue with F10.

However, I just upgraded to F11 and the audio works again!  So now, I'll keep better track of whether the audio stops working after an upgrade...  Removing me from CC.
Comment 6 Bug Zapper 2009-07-14 10:13:54 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.