Bug 471782 - Please build audacity against the system portaudio
Please build audacity against the system portaudio
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 03:05 EST by Kevin Kofler
Modified: 2008-11-16 16:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-16 16:26:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2008-11-16 03:05:06 EST
Description of problem:
I'm currently working on making PortAudio work with PulseAudio:
http://techweb.rfa.org/pipermail/portaudio/2008-November/008990.html
It would be nice if I would have just one package to patch, and especially not rebuild all of Audacity just to test my changes. Unfortunately, Audacity is currently built against a private copy of PortAudio.

Version-Release number of selected component (if applicable):
audacity-0:1.3.5-0.7.beta.fc9

How reproducible:
Always

Steps to Reproduce:
1. Check dependencies of Audacity.
  
Actual results:
Uses private PortAudio.

Expected results:
Uses system PortAudio.

Additional info:
Using private copies of system libraries is also against our packaging guidelines. I understand this was needed when Audacity required PortAudio v19 and the system copy was only v18, but the system copy is also v19 now.
Comment 1 Kevin Kofler 2008-11-16 03:07:18 EST
See also https://bugzilla.rpmfusion.org/show_bug.cgi?id=162 against audacity-freeworld.
Comment 2 Michael Schwendt 2008-11-16 03:50:12 EST
WONTFIX and CANTFIX. We are aware of the "portaudio" package.
The included PortAudio is built with because it is both a snapshot
from svn and patched for Audacity (also to support PortMixer).
Comment 3 Kevin Kofler 2008-11-16 16:26:27 EST
Well, OK then. I still think ultimately the changes should get into PortAudio upstream, but I see not much can be done for now.

I will file bugs to merge my PulseAudio (or rather: ALSA without dmix) patches instead (once I tested them to actually work).
Comment 4 Kevin Kofler 2008-11-16 16:27:00 EST
I mean "ALSA without mmap" of course, not "without dmix".

Note You need to log in before you can comment on or make changes to this bug.