Bug 4718 - ftpwho command produces erroneous output after wu-ftpd-2.5.0-5.5.x update
ftpwho command produces erroneous output after wu-ftpd-2.5.0-5.5.x update
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-26 05:43 EDT by gbayley
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-16 07:40:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gbayley 1999-08-26 05:43:08 EDT
Following installation of the wu-ftpd-2.5.0-5.5.x package
today regarding the security issue in wu-ftp versions up to
and including 2.5, the ftpwho command now produces erroneous
output, as below.

[root@ausmac gbayley]# ftpwho
Service class all:
warning: `-' deprecated; use `ps f', not `ps -f'
warning: `-' deprecated; use `ps p', not `ps -p'
 7242  ?  S    0:00 ftpd: gzunda.kazoo.com.au: gbayley: IDLE
   -   1 users (no maximum)
[root@ausmac gbayley]#


Although I've not been able to test this out on other
versions of RedHat I imagine the same bug exists in the
version supplied for RedHat 6.0.  It's certainly there in a -
-rebuild constructed RPM file.

Hope this helps,

Grant
Comment 1 Preston Brown 1999-08-26 23:17:59 EDT
argh, this is because "LINUX_BUT_NOT_REDHAT_6_0" wasn't defined when
building for 5.x and 4.2.  It works fine on 6.0 and later.

I think this merits a rebuild, unfortunately.

Note You need to log in before you can comment on or make changes to this bug.