Bug 471800 - Driver for dm9601 doesn't seem to work as advertised
Driver for dm9601 doesn't seem to work as advertised
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ivan Vecera
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 11:42 EST by Colin.Simpson
Modified: 2009-09-02 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 04:46:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Final patch sent to review (13.21 KB, patch)
2008-12-19 05:17 EST, Ivan Vecera
no flags Details | Diff

  None (edit)
Description Colin.Simpson 2008-11-16 11:42:23 EST
Description of problem:

Plugging in a USB based DM9601 Davicom Ethernet Adaptor doesn't work.
It sometimes pings other hosts but it's intermittent and unreliable. 

This driver was added in 5.2 kernels i.e. from the 5.2 kernel release notes:

* add dm9601 driver support for DAVICOM's ZT6688

I have tried various kernels since then and none work 

kernel-2.6.18-92.el5 thru to the latest kernel-2.6.18-92.1.18.el5

I've also tried various other USB adaptors using this chip set and none work. (I can post you one if you like, they aren't good for me at the moment )

The only way I've ever got this to work reliable was to use an earlier RH kernels and hand compile the upstream (pre kernel merged probably) driver. Then it works reliably. 

Version-Release number of selected component (if applicable):

It's been broken since the release of 5.2 (and it was new feature then).

How reproducible:
Every Time

Steps to Reproduce:
1.Plug it in
2.ifconfig the new interface 
3.Try and ping machines on this network
  
Actual results:
Long ping times and general unreliability (dropped packets and slow)

Expected results:
Reliable connection

Additional info:
Comment 1 Ivan Vecera 2008-11-18 10:57:08 EST
I tried to backport dm9601 from upstream. Could you please test it? Kernel packages are available at:
http://people.redhat.com/ivecera/rhel-5-ivtest/
Comment 2 Colin.Simpson 2008-11-18 13:48:59 EST
Yes that looks like it works. The ethernet seems a lot happier now. Great.

Though a regression I see with this kernel is that on an i810 chip set, going to a virtual console then back to X causes a white screen to appear and no X being visible. This was a problem on early RH5 kernels we saw but was fixed a while back. I don't know but maybe this kernel doesn't have all the patches that the present release kernel has. I just mention it FYI.

Let me know when/if you plan to integrate this fix into a bug fix release. Thanks for the swift response.
Comment 3 Ivan Vecera 2008-12-19 05:17:30 EST
Created attachment 327423 [details]
Final patch sent to review
Comment 4 Colin.Simpson 2009-01-22 13:32:11 EST
This didn't make it into 5.3, any reason why? Or will it appear in a future bug fix kernel release.
Comment 6 RHEL Product and Program Management 2009-01-27 15:39:12 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 RHEL Product and Program Management 2009-02-16 10:40:41 EST
Updating PM score.
Comment 12 errata-xmlrpc 2009-09-02 04:46:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2009-1243.html

Note You need to log in before you can comment on or make changes to this bug.