Bug 471825 - sos-1.8-2.fc10.noarch conflicts with sysreport-1.4.4-1.noarch
sos-1.8-2.fc10.noarch conflicts with sysreport-1.4.4-1.noarch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sos (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Navid Sheikhol-Eslami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 19:07 EST by Mads Kiilerich
Modified: 2009-01-21 14:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 14:52:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-11-16 19:07:35 EST
Description of problem:

  file /usr/sbin/sysreport from install of sos-1.8-2.fc10.noarch conflicts with file from package sysreport-1.4.4-1.noarch
  file /usr/share/sysreport/functions from install of sos-1.8-2.fc10.noarch conflicts with file from package sysreport-1.4.4-1.noarch

At a quick glance sos uses names in the namespace obviously belonging to sysreport.

IIRC sos was in default installations for older systems while sysreport is in yum group "Base" now, so a conflict is pretty likely. 

It looks a bit like sos was intended to deprecate sysreport. But Fedora goes the other way?

If one is intended to replace the other, then the rpm metadata should cause yum to do it and resolve the situation. If they really are alternatives then the alternative system should be used.

Well ... the short version: I don't get it. But it looks like a problem which shouldn't be there.


Version-Release number of selected component (if applicable):

sos-1.8-2.fc10.noarch
sysreport-1.4.4-1.noarch
Comment 1 Bug Zapper 2008-11-26 00:29:53 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 David Fraser 2009-01-07 03:19:07 EST
I got this after a yum upgrade from Fedora 8 to Fedora 10 and trying to groupinstall Base... it would be helpful just to know whether there is a plan to stick with sos or switch to sysreport
Comment 3 Mads Kiilerich 2009-01-15 11:30:21 EST
I just noticed that sos-1.8-6.fc10 from updates-testing replaces sysreport-1.4.4-1. So ... that seems to be the plan ;-)

That means that "yum info sysreport" soon shows info about sysreport, but "yum install sysreport" actually installs sos...
Comment 4 Adam Stokes 2009-01-21 14:52:28 EST
Hi,

sosreport is/has replaced sysreport from here on out.

Hope this helps.

Thanks!
Adam

Note You need to log in before you can comment on or make changes to this bug.