Bug 471833 - use lowercase input-method names
use lowercase input-method names
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
: FutureFeature, i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 22:57 EST by Jens Petersen
Modified: 2009-03-10 06:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-10 06:49:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-11-16 22:57:12 EST
Description of problem:
It would be nice if imsettings used a NAME variable in xinput files to carry a lowercase name of input-methods.

Steps to Reproduce:
1. imsettings-list
2. imsettings-start SCIM
3.
  
Actual results:
1. list SHORT_DESC name which is often mixed or uppercase.

Expected results:
1. list input-method names in lowercase.
2. able to start scim with "imsettings-start scim", etc
Comment 1 Akira TAGOH 2008-11-19 06:50:49 EST
I'd rather prefer just dealing with it as case-insensitive string, because that way could be easily set to the unrelated name and it would makes confused.
Comment 2 Jens Petersen 2008-11-19 21:07:53 EST
I would rather take NAME as the default and use SHORT_DESC to override it in im-chooser: then imsettings-list will show lowercase names and it will be more consistent IMHO.
Comment 3 Jens Petersen 2008-11-19 21:09:06 EST
(Maybe an alternative to NAME would be just using the filename with .conf?)
Comment 4 Akira TAGOH 2009-01-05 03:50:35 EST
Okay. will change the behavior to fall back to the conf filename with/without .conf if no such names in the list of SHORT_DESC then.
Comment 5 Jens Petersen 2009-01-05 21:15:15 EST
So what will imsettings-list show in that case?
Comment 6 Akira TAGOH 2009-01-05 21:49:00 EST
no plans to change it. guess better improving a help message in imsettings-start instead. actually current description of parameter doesn't clarify it would links to what imsettings-list shows.
Comment 7 Jens Petersen 2009-01-05 21:55:59 EST
So you are going the case-insensitive way or just wontfix?
Comment 8 Akira TAGOH 2009-01-06 04:15:45 EST
I meant no plans to change imsettings-list but only update an interface for imsettings-start/stop/restart to a case-insensitive name or a filename with/without .conf.

From some discussion with you on IRC, I'm going to change imsettings-list like:

* 1: /etc/X11/xinit/xinput.d/scim.conf (recommended)
  2: /etc/X11/xinit/xinput.d/ibus.conf

or

* 1: scim.conf (recommended)
  2: ibus.conf

or whatever. and allow a filename with/without .conf suffix for imsettings-start/stop/restart then.
Comment 9 Akira TAGOH 2009-01-20 21:53:45 EST
tried the above idea and facing an issue for XIM. imsettings doesn't manage xinput conf for XIM directly but accessing through xim.conf to get the right thing for current locale. the above idea makes harder to see which legacy XIM server will be used really. that may makes sense at some point that one is surely enabling XIM though. displaying SHORT_DESC too may be good perhaps.
Comment 10 Akira TAGOH 2009-02-24 21:17:12 EST
Fixed in imsettings-0.106.0-1.fc11.

Note You need to log in before you can comment on or make changes to this bug.