Bug 471848 - Recent kernels start dropping interrupts on i915
Recent kernels start dropping interrupts on i915
Status: CLOSED DUPLICATE of bug 471162
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 00:52 EST by Ben Gamari
Modified: 2008-11-17 10:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 10:36:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Gamari 2008-11-17 00:52:16 EST
Description of problem:
Recent kernels (noticed it around -109 I think) start dropping interrupts on my i965, causing extremely poor redraw characteristics (screen updates failing to occur until mouse movement, etc).


irq 16: nobody cared (try booting with the "irqpoll" option)
Pid: 0, comm: swapper Not tainted 2.6.27.5-109.fc10.x86_64 #1

Call Trace:
 <IRQ>  [<ffffffff8108320f>] __report_bad_irq+0x38/0x7c
 [<ffffffff8108345b>] note_interrupt+0x208/0x26d
 [<ffffffff81083b88>] handle_fasteoi_irq+0xbb/0xeb
 [<ffffffff8101309e>] do_IRQ+0xf7/0x169
 [<ffffffff81010933>] ret_from_intr+0x0/0x2e
 <EOI>  [<ffffffff811bcc5a>] ? acpi_idle_enter_simple+0x175/0x1b4
 [<ffffffff811bcc52>] ? acpi_idle_enter_simple+0x16d/0x1b4
 [<ffffffff81286063>] ? cpuidle_idle_call+0x95/0xc9
 [<ffffffff8100f279>] ? cpu_idle+0xb2/0x10b
 [<ffffffff8131f33d>] ? rest_init+0x61/0x63

handlers:
[<ffffffffa034b46f>] (i915_driver_irq_handler+0x0/0x199 [i915])
Disabling IRQ #16
wlan0: disassociating by local choice (reason=3)
wlan0: authenticate with AP 00:1c:0e:40:ec:2f
wlan0: authenticated
wlan0: associate with AP 00:1c:0e:40:ec:2f
wlan0: RX AssocResp from 00:1c:0e:40:ec:2f (capab=0x1 status=0 aid=3)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
irq 16: nobody cared (try booting with the "irqpoll" option)
Pid: 25570, comm: Xorg Not tainted 2.6.27.5-109.fc10.x86_64 #1

Call Trace:
 <IRQ>  [<ffffffff8108320f>] __report_bad_irq+0x38/0x7c
 [<ffffffff8108345b>] note_interrupt+0x208/0x26d
 [<ffffffff81083b88>] handle_fasteoi_irq+0xbb/0xeb
 [<ffffffff81011bcc>] ? call_softirq+0x1c/0x28
 [<ffffffff8101309e>] do_IRQ+0xf7/0x169
 [<ffffffff81010933>] ret_from_intr+0x0/0x2e
 <EOI>  [<ffffffff8109eb8d>] ? unmap_vmas+0x462/0x894
 [<ffffffff8109eb8d>] ? unmap_vmas+0x462/0x894
 [<ffffffff810a314b>] ? exit_mmap+0x8c/0x105
 [<ffffffff8103f3e1>] ? mmput+0x42/0x9f
 [<ffffffff810c4a17>] ? flush_old_exec+0x48a/0x7bf
 [<ffffffff810c076d>] ? vfs_read+0xcd/0x102
 [<ffffffff810f50d5>] ? load_elf_binary+0x39f/0x16c2
 [<ffffffff810c3ebe>] ? get_arg_page+0x4b/0xab
 [<ffffffff810c41db>] ? copy_strings+0x1d2/0x1e3
 [<ffffffff810c42fc>] ? search_binary_handler+0xc2/0x23a
 [<ffffffff810c55b9>] ? do_execve+0x1c3/0x275
 [<ffffffff810ca0de>] ? getname+0x16c/0x1d2
 [<ffffffff8100e643>] ? sys_execve+0x3e/0x59
 [<ffffffff810107ba>] ? stub_execve+0x6a/0xc0

handlers:
[<ffffffffa034b46f>] (i915_driver_irq_handler+0x0/0x199 [i915])
Disabling IRQ #16
Comment 1 Paul W. Frields 2008-11-17 10:36:08 EST

*** This bug has been marked as a duplicate of bug 471162 ***

Note You need to log in before you can comment on or make changes to this bug.