This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 471857 - Pidgin can not be launched in Server5.2
Pidgin can not be launched in Server5.2
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pidgin (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Warren Togami
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 03:16 EST by Suqin Huang
Modified: 2009-04-03 08:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-23 14:22:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2008-11-17 03:16:04 EST
Description of problem:
An error "pidgin:undefined symbol:gst_registry_fork_set_enabled" occur when launched pidgin in Server-5.2

Version-Release number of selected component (if applicable):
pidgin-2.5.1-3.el5
RHEL-Server-5.2-i386

How reproducible:
Always

Steps to Reproduce:
Work in local machine :
1. Created a yum resource 
the baseurl= http://10.66.82.101/redhat/rhel/rel-eng/RHEL5.3-Client-20081112.0/tree-i386/Client/
and http://10.66.82.101/redhat/rhel/rel-eng/RHEL5.3-Client-20081112.0/tree-i386/Workstation/
2. update libpurple and then update pidgin.
3. launch pidgin.

Work in remote stable system:
1. tps-cd 2009:8176
2. yum install libpurple
3. tps-upgrade (the version is pidgin-2.5.1-3.el5.i386)
4. vncserver to 
5. user tps-downgrade to downgrade pidgin. (the version is pidgin-2.3.1-2.el5_2.i386)
Actual results:
1. An error "pidgin:undefined symbol:gst_registry_fork_set_enabled" occur when launch pidgin.
2. After downgrading pidgin, it can work well.

Expected results:


Additional info:
pidgin-2.5.1-3.el5.i386 can work well in RHEL-Server5.3
Comment 1 Suqin Huang 2008-11-17 20:47:32 EST
The description above is how did I install pidgin-2.5.1-3.el5.

In short:
After installing pidgin-2.5.1-3.el5 in RHEL-Server-5.2, issue "pidgin" in terminal, an error "pidgin:undefined symbol:gst_registry_fork_set_enabled" is displayed.


In RHEL-Server-5.3, pidgin-2.5.1-3.el5 can be launched successfully.
Comment 2 Mark Doliner 2008-11-17 21:08:36 EST
That would happen if Pidgin was compiled on a machine with a version of gstreamer that had the gst_registry_fork_set_enabled function, but used on a machine with an older version of gstreamer which does not have that function.
Comment 3 Warren Togami 2008-11-23 14:22:14 EST
NOTABUG, you cannot use RHEL-5.3 compiled pidgin on RHEL-5.2.

http://people.redhat.com/wtogami/temp/pidgin/
Please test these binaries.  Low priority security errata is coming soon, built against RHEL-5.2 so it should work on both RHEL-5.2 and RHEL-5.3.  It will supercede the current 5.3 version.
Comment 4 Suqin Huang 2008-11-23 20:22:29 EST
en, after I update gstreamer, pidgin can be launched.
Comment 5 Warren Togami 2008-11-24 06:19:28 EST
Turns out that build of pidgin was screwed because the RHEL-5.3 gstreamer was in the buildroot.  I am rebuilding it against RHEL-5.2.  The pidgin security errata coming soon will be RHEL-5.2, and identical without a rebuild in 5.3.

Note You need to log in before you can comment on or make changes to this bug.