Bug 471860 - Fatal server error: DRM Command submission failure -22
Fatal server error: DRM Command submission failure -22
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 03:45 EST by Jóhann B. Guðmundsson
Modified: 2008-12-01 05:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 05:16:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (65.38 KB, text/plain)
2008-11-17 03:45 EST, Jóhann B. Guðmundsson
no flags Details
Photo of gdm when starting.. (1.44 MB, image/jpeg)
2008-11-17 03:46 EST, Jóhann B. Guðmundsson
no flags Details
startx from cli (78.19 KB, text/plain)
2008-11-19 02:32 EST, Jóhann B. Guðmundsson
no flags Details
Xorg log (139.52 KB, text/plain)
2008-11-19 02:37 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2008-11-17 03:45:36 EST
Created attachment 323744 [details]
Xorg.0.log

Description of problem:
X crashes..

Fatal server error: 
DRM Command submission failure -22

Card ATI Radeon X1650 Pro ( VPU ) Sapphire... 

Version-Release number of selected component (if applicable):

Kernel 5-109
drv-ati -46

How reproducible:

Always

Steps to Reproduce:
1. Boot in runlevel 5
2. run startx
3.
  
Actual results:

X crashes  

Expected results:

X working

Additional info:
Comment 1 Jóhann B. Guðmundsson 2008-11-17 03:46:39 EST
Created attachment 323745 [details]
Photo of gdm when starting..
Comment 2 Jóhann B. Guðmundsson 2008-11-17 03:50:47 EST
Noticed this when running startx from cli and X fails..
(EE) RADEON(0): [drm] Failed to initialize GART heap manager..
Comment 3 Jóhann B. Guðmundsson 2008-11-18 06:03:16 EST
With kernel -116 and -ati 51 GDM does not freeze.
Less pink stripes and mousepointer visible 
( can move the pointer without problem )

Not seeing this in log..

DRM Command submission failure -22

But this is still present..

(EE) RADEON(0): [drm] Failed to initialize GART heap manager..

And this is new... 

RADEON DRM CS failure - corruptions/glitches may occur -12
bufmgr: last submission...
Comment 4 Jóhann B. Guðmundsson 2008-11-19 02:32:05 EST
Created attachment 324007 [details]
startx from cli
Comment 5 Jóhann B. Guðmundsson 2008-11-19 02:37:14 EST
Created attachment 324009 [details]
Xorg log

With kernel -120 and ati -54 we have X stuck in a infinite loop  :) 

[mi] EQ overflowing. The server is probably stuck in an infinite loop.
Comment 6 Matěj Cepl 2008-11-19 06:23:21 EST
Looks like this is more an evdev issue. Reassigning.

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x812b9ab]
1: /usr/bin/X(mieqEnqueue+0x289) [0x810b0c9]
2: /usr/bin/X(xf86PostMotionEventP+0xc2) [0x80d3fb2]
3: /usr/bin/X(xf86PostMotionEvent+0x68) [0x80d4118]
4: /usr/lib/xorg/modules/input//evdev_drv.so [0x569a8d]
5: /usr/bin/X [0x80bcb17]
6: /usr/bin/X [0x80ac67e]
7: [0x110400]
8: /lib/libc.so.6(memcpy+0x46) [0x873626]
9: [0xaddeb000]
10: /usr/lib/xorg/modules//libfb.so(fbCopyNtoN+0x1a5) [0x2fb795]
11: /usr/lib/xorg/modules//libexa.so(exaCopyNtoN+0x2c0) [0x315e50]
12: /usr/lib/xorg/modules//libexa.so(exaComposite+0x856) [0x31b3b6]
13: /usr/bin/X [0x816f27a]
14: /usr/bin/X(CompositePicture+0x19a) [0x8157eda]
15: /usr/lib/xorg/modules//libexa.so [0x316bbd]
16: /usr/lib/xorg/modules//libexa.so(exaGlyphs+0x4e2) [0x317612]
17: /usr/bin/X [0x816f545]
18: /usr/bin/X(CompositeGlyphs+0xa2) [0x8154362]
19: /usr/bin/X [0x81616ce]
20: /usr/bin/X [0x815aac5]
21: /usr/bin/X(Dispatch+0x34f) [0x8085e6f]
22: /usr/bin/X(main+0x47d) [0x806b6ed]
23: /lib/libc.so.6(__libc_start_main+0xe5) [0x8106d5]
24: /usr/bin/X [0x806aad1]
Comment 7 Jóhann B. Guðmundsson 2008-11-19 09:17:11 EST
Perhaps a combination of both since the trace did not happen until I
update the ati to -54..
Comment 8 Dave Airlie 2008-11-19 16:14:08 EST
no its an exa problem

have you installed the latest X server?
Comment 9 Peter Hutterer 2008-11-19 17:40:29 EST
Matej:
the x server forces a backtrace when the EQ overflows. EQ overflow happens usually during SIGIO handling when input still works but something else is stuck. 
Since input still works, the first few lines in the backtrace will always be input related, but the interesting stuff (i.e. what causes the overflow) is south of the signal handler.
Comment 10 Jóhann B. Guðmundsson 2008-11-20 02:44:01 EST
xserver 1.5.3-5 (now)ati -55 kernel -120

Any extra debugging info needed?
Comment 11 Bug Zapper 2008-11-26 00:30:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Jóhann B. Guðmundsson 2008-11-30 23:09:20 EST
I updated to ati -60 and kernel 7-132 and this issue can be closed 
as FIXED :)

Nice job everyone..
Comment 13 Matěj Cepl 2008-12-01 05:16:35 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.