Bug 471883 - Anaconda install fails with inserted SD card in write-protected mode [NEEDINFO]
Anaconda install fails with inserted SD card in write-protected mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Hans de Goede
Alexander Todorov
:
Depends On:
Blocks: 5.4/TechnicalNotes
  Show dependency treegraph
 
Reported: 2008-11-17 09:28 EST by Adam Stokes
Modified: 2010-10-23 01:59 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
clumens: needinfo? (astokes)


Attachments (Terms of Use)
anaconda trace (467.83 KB, text/plain)
2008-11-17 09:28 EST, Adam Stokes
no flags Details
install logs from recent replication (4.62 KB, application/octet-stream)
2009-07-22 12:04 EDT, Chris Tatman
no flags Details
install logs from recent replication (50.90 KB, text/plain)
2009-07-22 12:04 EDT, Chris Tatman
no flags Details
screenshot of error1 (899.39 KB, image/jpeg)
2009-07-22 12:06 EDT, Chris Tatman
no flags Details
screenshot of error 2 (627.45 KB, image/jpeg)
2009-07-22 12:13 EDT, Chris Tatman
no flags Details
anaconda.log from 0724.nightly install with SD card attached. (410.65 KB, text/plain)
2009-07-24 06:02 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Adam Stokes 2008-11-17 09:28:06 EST
Created attachment 323765 [details]
anaconda trace

Description of problem:
With the SD cards installed with the switch set to Read Only, the RHEL 5.2 installation will complain “Unable to open /dev/sdX – Read Only” and  “Can’t mount /tmp/sdX” a huge number of times.  After acknowledging these and removing it from the HDD install option (i.e. only install to sda, etc.), Anaconda continues with the install process.  After packages have been selected,the installer will fail and exit after the actual install begins with a trace.This happens with both text and graphical install.

Version-Release number of selected component (if applicable):


How reproducible:
100 %

Steps to Reproduce:
1. Perform install with read-only sd card
2. De-select the sd card from partition druid
3.
  
Actual results:
Anaconda trace attached

Expected results:
Installer honors the deselection of the sd card and performs the installation on selected media

Additional info:
Does not occur in f9 or later
Comment 1 Chris Lumens 2008-11-17 10:15:55 EST
Please attach the traceback to this bug report so we can actually see what and where it's failing.
Comment 2 Adam Stokes 2008-11-17 10:23:37 EST
Is that not what I attached?
Comment 4 Hans de Goede 2008-11-26 05:32:58 EST
(In reply to comment #2)
> Is that not what I attached?

Yes it is, sorry. We can reproduce this and we will put it on the list of things which we might fix for 54, if it will make the final list depends upon how many other issues there will be and how urgent those will be.
Comment 5 John Feeney 2008-12-03 10:24:15 EST
Just to help move thinks along with regard to this bz, there is a system in
Westford where this bug can be replicated and I have a SD card and know how to
install it so just let me know if I can be of any help.
Comment 7 Hans de Goede 2008-12-10 05:32:31 EST
I've prepared an updates.img which contains the fix as we plan to apply in RHEL 5.4 (assuming this issue makes the list of things to fix for 5.4), you can find it here:
http://people.atrpms.net/~hdegoede/updates471883.img

You can use this as a workaround for this bug (on a system with an internet connection) by specifying:
updates=http://people.atrpms.net/~hdegoede/updates471883.img

As boot parameter.

Feel free to move this updates.img to a redhat.com address (I still need to setup my personal webspace @redhat.com)
Comment 8 RHEL Product and Program Management 2009-02-03 18:15:32 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 26 Hans de Goede 2009-05-06 08:20:59 EDT
This is fixed in this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=8197619b66a84dc1ce625aa80100e99568417fb7

Which will be part of the upcoming anaconda-11.1.2.173-1 build.
Comment 33 Chris Tatman 2009-07-22 12:04:03 EDT
Created attachment 354726 [details]
install logs from recent replication
Comment 34 Chris Tatman 2009-07-22 12:04:51 EDT
Created attachment 354727 [details]
install logs from recent replication
Comment 35 Chris Tatman 2009-07-22 12:06:00 EDT
Created attachment 354728 [details]
screenshot of error1
Comment 36 Chris Tatman 2009-07-22 12:13:25 EDT
Created attachment 354730 [details]
screenshot of error 2
Comment 44 John Feeney 2009-07-23 14:02:26 EDT
Okay, my SD card in "Lock" mode is in dell-per805-01.rhts.bos.redhat.com. Sorry, I wasn't aware it was reserved waiting for me. Oh, well. Please feel free to use it to see how the install goes. Please let me know when the reservation time period has expired so I can retrieve my card.

With regard to me helping testing this, I believe Dell has already provided their feedback so me adding anything would be superflous, in my opinion.

With regard to Dell's feedback, it looks to me as though the flood of read-only popups are gone with Chris' anaconda so I would consider this bug to be fixed, once officially released. Dell would like an explanation of why there is a warning message but that should not stop this bz from being considered resolved. Again in my opinion, since this warning does not prevent the installation from occurring (at least that is what it looks like) and IF it is deemed a bug (I have no opinion right now), I would suggest one be opened and it fixed in a future release.
Comment 45 Alexander Todorov 2009-07-24 06:01:44 EDT
I've tested snap #4 with the updates.img from Chris on dell-per805-01 with Sd card in read-only mode attached. 
- No warnings for read-only storage in the GUI were shown. 
- /dev/sdb (the SD card) was not present on the partitioning screen, only /dev/sda
- default install completed without errors. I'll attach anaconda.log
- no warning about loop partition layout was seen as in comment #43

Also tested with 0724.nightly build which has anaconda-11.1.2.193-1 (and no updates.img). Same results. 

I'm moving this to VERIFIED. The loop partition warning in comment #43 is probably due to machine/disc specific issue.
Comment 46 Alexander Todorov 2009-07-24 06:02:59 EDT
Created attachment 354996 [details]
anaconda.log from 0724.nightly install with SD card attached.
Comment 51 errata-xmlrpc 2009-09-02 05:52:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.