Bug 471892 - pulseaudio not "glitch-free" for KDE - at least for system sounds. bad first impression
pulseaudio not "glitch-free" for KDE - at least for system sounds. bad first ...
Status: CLOSED DUPLICATE of bug 466314
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 10:06 EST by Jason Farrell
Modified: 2010-12-07 13:41 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 10:46:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2008-11-17 10:06:42 EST
I know pulseaudio is supposed to be "glitch-free" in F10, but did anyone even *try* logging in to KDE4 even once?

The default startup & shutdown KDE sounds are still as choppy as they were in F9; the startup sound never even finishes skipping before being cut off. This leaves a bad taste in your mouth for KDE, even if subsequent audio playback in other apps is OK.

The Gnome startup sounds on the same F10 system are however glitch-free.

No love for KDE?
Comment 1 Rex Dieter 2008-11-17 10:10:35 EST
It's highly dependent on audio hardware and drivers (kernel).

So, what audio hw are you using?

and,
rpm -q kernel
uname -a kernel

please.
Comment 2 Jason Farrell 2008-11-17 10:35:37 EST
Using the very common Audigy card:
01:08.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value

[root@nano ~]# lspci|grep audio ; rpm -q kernel ; uname -a
01:08.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value
kernel-2.6.27.4-68.fc10.x86_64
kernel-2.6.27.5-109.fc10.x86_64
Linux nano 2.6.27.5-109.fc10.x86_64 #1 SMP Thu Nov 13 20:12:05 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Rex Dieter 2008-11-17 10:46:02 EST
thanks, looks like a dup of bug #466314

*** This bug has been marked as a duplicate of bug 466314 ***
Comment 4 Jason Farrell 2008-11-17 11:10:56 EST
If it is a dupe (audigy2 buffer underruns) then it's very odd that it's really only KDE syssounds with the bad skipping problem. pulseaudio is otherwise perfectly fine on my system.

Thanks Rex.

btw - why is kde-settings-pulseaudio-4.1-4.20081031svn.fc10.noarch installed if it contains no files or scripts? old dep? ... looks like nothing requires it, but it's still in the kde-desktop comps group.
Comment 5 Rex Dieter 2008-11-17 11:27:24 EST
kde-settigs-pulseaudio is a metapackage with Requires to pull in all the necessary stuff to make PA work, including:
pulseaudio
pulseaudio-module-x11
alsa-plugins-pulseaudio
xine-lib-pulseaudio
Comment 6 Rex Dieter 2009-02-02 11:29:51 EST
In the mean time, we've patched xine-lib (1.1.16.1) in an attempt to workaround some of the pa-induced choppiness.

Note You need to log in before you can comment on or make changes to this bug.