This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 471937 - "disabling IRQ #16" -> hang
"disabling IRQ #16" -> hang
Status: CLOSED DUPLICATE of bug 471162
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 14:03 EST by Andrew Overholt
Modified: 2009-01-27 12:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-22 03:27:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (101.09 KB, text/plain)
2008-11-18 15:56 EST, Joe Ammond
no flags Details
Picture of various ext3 errors (606.27 KB, image/jpeg)
2008-11-19 11:46 EST, Luke Macken
no flags Details

  None (edit)
Description Andrew Overholt 2008-11-17 14:03:22 EST
When running kernel-2.6.27.5-109.fc10.x86_64 I get random system-wide hangs and need to hard-reboot my laptop.  It appears that just before the hang I'm getting "disabling IRQ #16" from syslog.

Booting into 2.6.27.4-68.fc10.x86_64 has no issues that I can see (well, except for apparently not having a working bluetooth on my laptop ...).

Smolt profile:

http://www.smolts.org/show?uuid=pub_e3f57b99-cd86-4253-bc26-4427d1b2a226
Comment 1 Jeremy Katz 2008-11-17 19:14:15 EST
This sounds something like what Luke saw this morning
Comment 2 Luke Macken 2008-11-18 11:19:24 EST
Yep, I hit that same issue yesterday with 2.6.27.5-109.fc10.x86_64.
http://www.smolts.org/client/show/pub_9371d993-29e5-49e0-a2f5-03b892355f7e
Comment 3 Joe Ammond 2008-11-18 15:37:51 EST
I'm having the same issue as well.
http://smolts.org/show?uuid=pub_d7c2a873-95ec-45ff-9fdc-b2ffcd3e7d64
Comment 4 Joe Ammond 2008-11-18 15:56:54 EST
Created attachment 323962 [details]
Xorg.0.log
Comment 5 Joe Ammond 2008-11-18 15:58:21 EST
I had a lockup on kernel 2.6.27.4-68.fc10.x86_64 as well. I was flipping desktops in compiz and the laptop hard locked. Upon reboot, I noticed the following in /var/log/Xorg.0.log.old:

exaCopyDirty: Pending damage region empty!
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

(repeated lots of times).
Comment 6 Will Woods 2008-11-18 16:08:52 EST
(In reply to comment #5)
> I had a lockup on kernel 2.6.27.4-68.fc10.x86_64 as well. I was flipping
> desktops in compiz and the laptop hard locked. Upon reboot, I noticed the
> following in /var/log/Xorg.0.log.old:
> 
> exaCopyDirty: Pending damage region empty!
> [mi] EQ overflowing. The server is probably stuck in an infinite loop.

If I understand correctly that's a different bug - you have no "disabling IRQ" message, and a much older kernel. Perhaps it matches one of the bugs in the 'eq-overflow' tracker: https://bugzilla.redhat.com/showdependencytree.cgi?id=465884&hide_resolved=1

FWIW I can reproduce the "disabling IRQ #16" behavior here as well, on kernel -113 (intel cantiga graphics)
Comment 7 Will Woods 2008-11-18 20:39:41 EST
See also bug 471162, which describes the same symptoms but on i945GME. Appears to be fixed for those users now.
Comment 8 Thorsten Leemhuis 2008-11-19 01:11:49 EST
(In reply to comment #7)
> See also bug 471162, which describes the same symptoms but on i945GME. Appears
> to be fixed for those users now.

FWIW, not all of those that commented on bug 471162 have a 945GME -- tree of them seem to have a intel 965 chipset (to be precise: a GM965 according to two of the three reports)
Comment 9 Hedayat Vatankhah 2008-11-19 07:23:50 EST
I have the same problem recently with latest f10 kernels (I'm using intel GM 965 graphics card).
It happened while I didn't use any 3D applications or desktop effects.
Comment 10 Luke Macken 2008-11-19 11:46:20 EST
I'm pretty sure I encountered the same issue again today.  Both times happened while I was spinning a livecd using the livecd-creator, under fairly heavy disk i/o.  This time, I was able to switch to a console and see some ext3 errors (picture attached).  I'm not 100% sure that this is the same issue, but it did produce the same symptoms as before.
Comment 11 Luke Macken 2008-11-19 11:46:47 EST
Created attachment 324073 [details]
Picture of various ext3 errors
Comment 12 Chuck Ebbert 2008-11-19 12:59:52 EST
You can work around the IRQ disable problem by adding "noirqdebug" to the kernel boot options.
Comment 13 Andrew Overholt 2008-11-19 14:20:17 EST
I had similar ext3 errors to Luke when I ran into this issue.
Comment 14 Andrew Overholt 2008-11-20 10:54:05 EST
This is still happening with kernel-2.6.27.5-113.fc10.x86_64.
Comment 15 Thorsten Leemhuis 2008-11-20 11:10:56 EST
(In reply to comment #14)
> This is still happening with kernel-2.6.27.5-113.fc10.x86_64.

Did you try with 2.6.27.5-116.fc10.x86_64 or newer? That is out for two days now and solved the problem for a few users in Bug 471162
Comment 16 Andrew Overholt 2008-11-20 11:36:35 EST
I'm running 2.6.27.5-117.fc10.x86_64 now.  To get some disk churn I cleaned and rebuilt all of my projects in Eclipse.  I have a lot so this wasn't a small task.  I also started up Firefox and did some stuff in an terminal at the same time.  I haven't seen a hang yet.
Comment 17 Hedayat Vatankhah 2008-11-20 12:24:27 EST
Yesterday I had many hangs. But since I've updated my kernel to 2.6.27.5-117.fc10.x86_64 I had no crashes. Seems to be fixed now. :)
Comment 18 Luke Macken 2008-11-21 14:43:55 EST
I've been running 2.6.27.5-117.fc10.x86_64 all day under high i/o load without any problems.
Comment 19 Thorsten Leemhuis 2008-11-22 03:27:59 EST

*** This bug has been marked as a duplicate of bug 471162 ***

Note You need to log in before you can comment on or make changes to this bug.