Bug 471961 - System lockup when changing resolutions
System lockup when changing resolutions
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
card_965GM
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 16:24 EST by Máirín Duffy
Modified: 2009-11-08 04:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-08 04:53:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.39 KB, text/plain)
2008-11-17 16:24 EST, Máirín Duffy
no flags Details
xorg.0.log (194.23 KB, text/plain)
2008-11-17 16:24 EST, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2008-11-17 16:24:13 EST
Created attachment 323803 [details]
xorg.conf

Description of problem:

This may be an X bug or something else, but I'm filing under system-config-display since I think that is the application I used that seemed to trigger the bug.

I have an x61 Thinkpad Tablet. I'll attach the xorg.conf to this bug for reference. 

I was switching from my native 1400x1050 resolution down to 1024x768 to do some website testing. If I use the tool at System > Preferences > Hardware > Screen Resolution, switching down to 1024x768 worked fine. However, if I attempt to switch back to 1400x1050 resolution, things go quite awry. The system maintains 1024x768, but scaled to 1400x1050 such that I can see screen artifacts from before I switched down to 1024x768 in the first place, but I can only move my mouse within and click on things in the 1024x768 'picture in picture' window after switching back up to 1400x1050.

In this state, if I attempt to restart x (ctrl+alt+backspace) or log out (System > Log out ...), the machine locks up hard. The caps lock key blinks and the system is unresponsive and I have to hard reset it and boot back up.

System > Administration > Display is similarly troublesome. When I tried this tool to switch from 1400x1050 => 1024x768, it didn't switch my resolution instantly the way the "Screen Resolution" tool did. Instead, it told me it had updated my xorg.conf file, and that I would need to restart X to see my new resolution. I restarted X (ctrl+alt+backspace method) and the system locked up hard again, with the caps lock light again blinking and in such a manner that necessitated a hard power cycle to get the machine responding again.

Version-Release number of selected component (if applicable):

system-config-display-1.1.1-1.fc10.noarch
xorg-x11-server-common-1.5.2-12.fc10.x86_64
kernel-2.6.27.4-79.fc10.x86_64

How reproducible:

Very reproducible, it seems to happen every time. 

Additional info:

Thinkpad x61 with 1400x1050 native resolution running rawhide/f10 and using the 'intel' display drivers with Wacom tablet settings in xorg.conf (attached) as well.
Comment 1 Máirín Duffy 2008-11-17 16:24:53 EST
Created attachment 323804 [details]
xorg.0.log

I don't know if there's helpful info in here but here it is just in case
Comment 2 Matěj Cepl 2008-11-20 11:26:12 EST
Screen resolution app is not system-config-display (but gnome-display-properties), s-c-d is mostly dead these days especially in Rawhide.

Reassigning.
Comment 3 Ray Strode [halfline] 2008-11-20 13:34:47 EST
gnome-display-properties is just a front end.  To me this sounds like a driver issue.
Comment 4 Matěj Cepl 2008-11-20 13:37:14 EST
yeah, hard lock machine, I am an idiot. Sorry, this is really not g-d-p.
Comment 5 Bug Zapper 2008-11-26 00:32:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Vedran Miletić 2009-11-05 18:11:44 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, including Intel driver, which may have resolved this issue.
To be more precise, Intel has undergone a major rewrite during Fedora 10, 11 and 12 cycles, and whole driver is working a lot better now. Users who have experienced this problem are encouraged to retry with at least Fedora 12 Beta and see if the issue is still relevant.

Please, if you experience this problem on Fedora 12 Beta or up-to-date system running Rawhide, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

We hope to see how many older bugs in Intel driver are still relevant today, in hope that most of them were fixed in rewrite process.

[This is a bulk message for all open Fedora 10 i810-related bugs (39 of them are still open). I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 7 Máirín Duffy 2009-11-07 19:25:07 EST
I am in Fedora 12 Rawhide right now and this is no longer a bug for me.
Comment 8 Matěj Cepl 2009-11-08 04:53:06 EST
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.