Bug 471978 - Constant reboot (startup udev)
Constant reboot (startup udev)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 19:30 EST by Theriel
Modified: 2013-01-10 02:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:52:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
acpidump (134.81 KB, text/plain)
2008-11-18 14:13 EST, Theriel
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 272530 None None None Never

  None (edit)
Description Theriel 2008-11-17 19:30:43 EST
Description of problem:
Fedora constantly reboots on loading while using laptop Samsung Q310

Version of Linux:
Fedora 10 Preview x64 Live

How reproducible:
Turn on Fedora with Live CD on Samsung Q310 (not confirmed in other notebooks). While booting (preferably without rhgb and without quiet) it gets to the point:

Welcome to Fedora. Press "I" to enter interactive startup.
Starting: udev

Then the system reboots.


Information from Ubuntu forum (http://tinyurl.com/6ol2mw) confirms similar problem. Suggested solutions on that forum:
-Booting with "acpi=off" or "acpi=ht" 
-With cpufreq disabled in the kernel, and the thermal and processor modules blacklisted then the system boots OK
-"Incidentally, everything seems to work perfectly on a 32bit LiveCD"
Comment 1 Theriel 2008-11-18 07:10:44 EST
Probable similarity to the bug 467519 (Samsung R560).
Comment 2 Harald Hoyer 2008-11-18 08:22:45 EST
blacklisting sounds like a kernel problem
Comment 3 Dave Jones 2008-11-18 11:20:03 EST
I suspect this machine has severely broken ACPI tables.
Can you install pmtools, run acpidump and attach the output ?
Comment 4 Theriel 2008-11-18 14:13:32 EST
Created attachment 323946 [details]
acpidump

This it the result of acpidump. I run it on the newest Madriva, which surprisingly started from LiveCD and worked without any problems - I hope this helps somehow.
Comment 5 Bug Zapper 2008-11-26 00:32:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Theriel 2008-11-26 21:15:04 EST
I am happy to inform you that this bug does not exist any longer.

The newest bios for Samsung Q310 + Fedora 10 (final) work perfectly.
Comment 7 Theriel 2008-12-23 07:09:20 EST
Unfortunately, I have to withdraw my previous statement.

My previous statement referred to Fedora 10 32 bit, which works OK. Nonetheless, the bug is still present on 64 bit version of Fedora. I am unable to boot without acpi=off parameter.
Comment 8 Theriel 2008-12-23 07:44:18 EST
Link to Ubuntu bugs, where people also refer to Fedora 10 and confirm the same problem: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/272530
Comment 9 JanS 2009-08-26 13:24:54 EDT
I can confirm this bug in Fedora 11 x86_64 Live
I have Samsung X360

On Fedora 11 i686 Live works very well, whereas on x86_64 it reboots constantly in endless loop.

Please change version of this bug from 10 to 11.

I am sure (from reading another posts and bug reports, eg. Ubuntu) that this is not only problem of Samsung Q310, R560, X360 but possibly for many more Samsung laptops.
Comment 10 Bug Zapper 2009-11-18 02:51:13 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-12-18 01:52:29 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.