Bug 47199 - (SOUND CS4281)cs4281 sound skips / stutters / pops under XMMS
Summary: (SOUND CS4281)cs4281 sound skips / stutters / pops under XMMS
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-03 22:55 UTC by Mike Zingale
Modified: 2008-08-01 16:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:39:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Zingale 2001-07-03 22:55:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.73C-SGI [en] (X11; U; IRIX64 6.5 IP30)

Description of problem:
I am running RH 7.1 on an IBM ThinkPad X20.  This machine has a cs4281
sound chip.  This
configuration worked fine with the 2.2.19 kernel under RH 7.0.  I am
currently running RH 7.1 with
2.4.3, and when playing sound with XMMS, the sound occassionally (every
10-20s) skips
or pops briefly.

My modules.conf has the following lines:

alias eth0 eepro100 
alias parport_lowlevel parport_pc 
alias usb-controller usb-uhci 
alias eth1  wvlan_cs

alias sound-slot-0 cs4281 
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || : 
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || : 



How reproducible:
Always

Steps to Reproduce:
1. Play an mp3 file with XMMS on an IBM ThinkPad x20 with a 2.4.x kernel
2.
3.
	

Actual Results:  Occassionally, the sound skips or pops during playback.

Expected Results:  There should be no popping in the playback

Additional info:

This worked fine under kernel 2.2.19

Comment 1 Landon Curt Noll 2001-09-06 03:16:46 UTC
It is interesting that this bug is similar, but not identical to bug
 #53293.

 We are using the same RH7.1 kernel, similar but not identical audio chip
 and laptop models.  XMMS fails completely on the IBM TP 770Z and play
 acts like the XMMS on the IBM TP X20.

Comment 2 Bugzilla owner 2004-09-30 15:39:04 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.