Bug 472030 - Retention policy doesn't work on thunderbird when incoming server is IMAP
Retention policy doesn't work on thunderbird when incoming server is IMAP
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 06:55 EST by koka xiong
Modified: 2009-12-08 17:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 17:59:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description koka xiong 2008-11-18 06:55:49 EST
Description of problem:
Retention policy doesn't work on thunderbird

Version-Release number of selected component (if applicable):
every version,from 1.5.0.12-17.el4 to 2.0.0.16-1.fc9

How reproducible:
always

Steps to Reproduce:
1.Choose Trash by click on it
2.Go to Edit->Folder Properties
3.In the popup window, click tab "Retention Policy"
4.Check option "Delete all but the last $NUMBER messages", set $NUMBER to 2.
5.Click "OK"
  
Actual results:
The message can't be deleted in the trash

Expected results:
The message should can be deleted in the trash

Additional info:
This problem happens when incoming server is set as IMAP mail server,pop3 is ok.
Comment 1 Matěj Cepl 2008-11-18 17:59:29 EST
You have to run File/Compact Folders to make the policy active for the first time.

NOTABUG
Comment 2 koka xiong 2008-11-19 03:40:07 EST
Thank you Matej Cepl.I have tried as you tell.But I find one issue:to make the policy active, every time I need to compact Folders,not just for the first time.
Comment 3 Mike A. Harris 2009-06-18 06:04:01 EDT
I chose "File->Compact Folders" in 2.0.0.21 and it does not seem to work, however if I right click directly on the folder with a retention policy and choose the "Compact" option, it causes the folder to flush mail older than the retention timeframe.  I'm not sure if thunderbird will auto-flush mail in that folder afterward or not, or if you have to constantly manually choose "compact".

What is odd is that I have thunderbird also configured to automatically compact mailboxes if 10000 bytes would be saved and that feature does not cause the mail to be flushed either.

Personally, I still consider this a bug because the majority of users who choose to set a retention policy of n days are neither informed that, nor are they likely to guess that they have to perform another action like "compact".  So if it isn't considered a bug per se. then it definitely is a design flaw.  Having said that, it probably belongs in the upstream bugzilla I guess.

Hopefully thunderbird 3 has a more intuitive design that works like one would expect.  :)
Comment 4 Massimo Canonico 2009-12-08 17:01:54 EST
Well, I think there is something that is not working properly here.

If I can accept to manually compact the folder in order to have my retention policy applied, I can accept the random deletion of my emails.

I have a IMAP account and my "Sent" folder retention policy says:
"Delete all but the last 4920 messages".

The folder is sort by ascending date, so the oldest mail should be the first to be deleted, but when I compact this folder, the email deleted is someone in the middle of my list.

Why? Is it a bug?

In my other POP account, everything perfectly works (to run the retention policy, I just have to jump over the folders, without compacting the folder).

What can I do? I'm using 2.0.0.23 TB, but even in TB3 there is this bug.

Thanks,
 M

Note You need to log in before you can comment on or make changes to this bug.