Bug 472044 - dbus-glib service error in standard tests
dbus-glib service error in standard tests
Status: CLOSED DUPLICATE of bug 472202
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus-glib (Show other bugs)
5.3
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: David Zeuthen
desktop-bugs@redhat.com
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 08:45 EST by Tomas Pelka
Modified: 2008-12-02 15:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 15:03:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2008-11-18 08:45:21 EST
Description of problem:
I'm testing dbus-glib through standard tests included in dbus-glib source codes.
There is one test called test-service-glib (in DBUS_GLIB_SRC/tests/core/),
which provides couple of methods that can be called via dbus. One of these methods causes error (see "Steps to reproduce" below).

Version-Release number of selected component (if applicable):
dbus-1.1.2-12.el5
dbus-glib-0.73-8.el5

How reproducible:
100%

Steps to Reproduce:
1. Download dbus-glib src and compile it with (./configure --enable-tests --enable-asserts).
2. Run test-service-glib (located in test/core).
3. Try send this message: 
	dbus-send --dest=org.freedesktop.DBus.GLib.TestService --print-reply --type=method_call /org/freedesktop/DBus/GLib/Tests/MyTestObject org.freedesktop.DBus.GLib.Tests.MyObject.StrHashLen dict:string:string:"key","value"
  
Actual results:

process 16443: arguments to dbus_message_iter_open_container() were incorrect, assertion "(type == DBUS_TYPE_STRUCT && contained_signature == NULL) || (type == DBUS_TYPE_DICT_ENTRY && contained_signature == NULL) || (type == DBUS_TYPE_VARIANT && contained_signature != NULL) || (type == DBUS_TYPE_ARRAY && contained_signature != NULL)" failed in file dbus-message.c line 2356.
This is normally a bug in some application using the D-Bus library.
process 16443: dbus message iterator looks uninitialized or corrupted
process 16443: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 16443: dbus message iterator looks uninitialized or corrupted
process 16443: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 16443: dbus message iterator looks uninitialized or corrupted
process 16443: arguments to dbus_message_iter_close_container() were incorrect, assertion "_dbus_message_iter_append_check (real_sub)" failed in file dbus-message.c line 2414.
This is normally a bug in some application using the D-Bus library.
method return sender=:1.845 -> dest=:1.863 reply_serial=2
   uint32 0

Expected results:

Should end without errors.

Additional info:
Comment 1 Matthias Clasen 2008-12-02 14:48:13 EST
This looks like a duplicate of bug 472202
Comment 2 Tomas Pelka 2008-12-02 15:02:48 EST
(In reply to comment #1)
> This looks like a duplicate of bug 472202

Yea Matthias,
same fail achieved by different ways.
Comment 3 Tomas Pelka 2008-12-02 15:03:23 EST

*** This bug has been marked as a duplicate of bug 472202 ***

Note You need to log in before you can comment on or make changes to this bug.