Bug 472045 - Enhanced user interface for boolean charts
Enhanced user interface for boolean charts
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 08:49 EST by Chris Ward
Modified: 2013-06-23 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 03:19:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2008-11-18 08:49:38 EST
Description of problem:
I work with the webui for creating boolean queries a lot. It's a long and slow process because each new field requires a full re-load of the search page. When i search and hit the back button, i often times lose the latest changes i made because the brower 'resends' the previous url it has in history rather than re-loading the cache that contained the most recent field changes too. This means *a lot* of duplicated effort, having to configure the various fields, etc.

It would be great if we could have the boolean query creation done without requiring a page reload.
Comment 1 David Lawrence 2008-12-15 11:27:49 EST
Actually this could be better if we just moved the boolean search to a separate cgi page of it's own. The downside is alot of people uses the boolean search fields in addition to the other more specific fields above. The boolean search fields would not really need to be ajax as the lists are not long. Adding/removing/editing boolean charts could be done entirely in client side javascript pretty quickly. Ajax is best for working with large data sets that you dont want to download everytime a page loads.
Comment 2 Chris Ward 2009-04-02 02:37:47 EDT
I aggree. This could be done using client side javascript only. So long as everytime i want to add/remove/update the charts i don't have to reload the entire page. Also, i don't want what's in the search, at the time of hitting 'GO' to disappear when i then hit 'back', if you know what i mean.
Comment 3 David Lawrence 2009-05-05 16:21:21 EDT
Actually I am not sure this needs to be done anymore. Since we did some work on the query.cgi advanced page to increase load speed, the boolean charts should be usable once again without the overhead of javascript.

Do you think this is now the case?

Dave
Comment 4 Chris Ward 2009-05-06 03:19:50 EDT
Yea, i did notice some speed improvements. Personally, i would still prefer to not have to reload the page for each additional boolean field i wanted to add, (i believe) it would speed my search workflows up tremendously. However, it seems that it would be a better job to get done upstream first. There are more pressing issues on the table for you guys than this atm. I'll close.

Note You need to log in before you can comment on or make changes to this bug.