Bug 472047 - Graphical install fails on Lenovo D10 - Quadro NVS 290 video
Graphical install fails on Lenovo D10 - Quadro NVS 290 video
Status: CLOSED DUPLICATE of bug 466347
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-nv (Show other bugs)
5.3
All Linux
medium Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 08:59 EST by Larry Troan
Modified: 2016-04-18 05:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 10:40:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport from running system after successful text install (623.49 KB, application/x-bzip)
2008-11-18 09:41 EST, Larry Troan
no flags Details
anaconda.log - text install (737.71 KB, text/x-log)
2008-11-18 15:20 EST, Larry Troan
no flags Details
associated anaconda.syslog (31.89 KB, application/octet-stream)
2008-11-18 15:20 EST, Larry Troan
no flags Details
sosreport after successful text install -- nv driver (636.00 KB, application/x-bzip)
2008-11-18 16:19 EST, Larry Troan
no flags Details
anaconda log at graphical failure (732.02 KB, image/jpeg)
2008-11-18 22:05 EST, Larry Troan
no flags Details
Anaconda logs after failure (help from jlaska) (24.16 KB, application/x-compressed-tar)
2008-11-19 09:15 EST, Larry Troan
no flags Details

  None (edit)
Description Larry Troan 2008-11-18 08:59:27 EST
Description of problem:
Attempting to do a graphical install using RHEL5.3 snapshot2 fails with xServer crashing. Same problem on RHEL5.2GA. RHEL5.1GA works fine.

How reproducible:
Attempt to install 5.3beta using a CD. Initial screens indicating loading the SAS driver appear, then screen goes dark. CNTL+ALT+BackSpace returns to a command line prompt.

Text install works.

When the system boots after a text install, startx works fine with the nv driver configured. Changing this to the VESA driver in /etc/X11/xorg.conf also works fine.

So it appears something in anaconda during install is not getting set up properly. 

Steps to Reproduce:
1. Boot RHEL5.3 snapshot 2 on a Lenovo ThinkStation D10 with NVS 290 video
2. Observe the dark screen after loading the SAS driver
3. CNTL+ALT+BackSpace gets you back to a command line prompt.
  
Actual results:
Graphical install fails.

Expected results:
Graphical install works as it did in RHEL5.1GA.

Additional info:
System in my Office. 

Brock also has a D10 in Raleigh.
Scott Dodson has an S10 in GSS support (whioch should have the same problem)
Comment 1 Larry Troan 2008-11-18 09:01:47 EST
Will try to get a dump of the xorg install log and a sysreport of the running machine after install completes.
Comment 2 RHEL Product and Program Management 2008-11-18 09:20:43 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Larry Troan 2008-11-18 09:41:04 EST
Created attachment 323905 [details]
sosreport from running system after successful text install
Comment 4 Adam Jackson 2008-11-18 10:37:44 EST
The X log in that sosreport is from a run with the vesa driver (which, unsurprisingly, appears to work).  Can I get a log from a run with the nv driver?

Alternatively, see if you have a file named /var/log/anaconda.xlog, which should be the X log from anaconda time.  IWBNI sosreport attached that directly, but, here we are.
Comment 5 Larry Troan 2008-11-18 15:20:04 EST
Created attachment 323956 [details]
anaconda.log - text install
Comment 6 Larry Troan 2008-11-18 15:20:43 EST
Created attachment 323957 [details]
associated anaconda.syslog
Comment 7 Larry Troan 2008-11-18 16:19:00 EST
Created attachment 323965 [details]
sosreport after successful text install -- nv driver
Comment 8 Larry Troan 2008-11-18 16:20:00 EST
Ajax, will try to capture the anaconda.log after a failed graphical install.
Comment 9 Larry Troan 2008-11-18 17:00:28 EST
Can't establish a network connection via dhclient eth0.

Installation sequence is as follows:

  Loading MPTSAS driver
     :
  Loading AHCI driver
     :
  Running Anaconda
     :
  Probing video
     :
  Waiting for xserver to start
     :
  "Input Not Supported" in box moving across screen
     :
     :

CNTL+ALT+BS (kill X)
     :

CNTL+ALT+F1 (switch to alternate xterm F1)
  
  1...2...3...4...5... Xserver started successfully
  Starting graphical installation... 
     


Will post a screen photo of the anaconda.log later tonight.
Comment 10 Larry Troan 2008-11-18 22:05:46 EST
Created attachment 323994 [details]
anaconda log at graphical failure
Comment 11 Larry Troan 2008-11-19 09:15:45 EST
Created attachment 324035 [details]
Anaconda logs after failure (help from jlaska)
Comment 12 Larry Troan 2008-11-19 09:17:20 EST
I only tried this on an x86_64 system but suspect it is all arches.
Comment 13 Adam Jackson 2008-11-19 10:40:13 EST
(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
(II) Module nv: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 2.1.6
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 1.0
...
(**) NV(0):  Default mode "800x600": 87.8 MHz (scaled from 0.0 MHz), 81.2 kHz, 65.0 Hz (D)
(II) NV(0): Modeline "800x600"   87.75  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync
(**) NV(0):  Driver mode "1280x1024": 108.0 MHz (scaled from 0.0 MHz), 64.0 kHz, 60.0 Hz
(II) NV(0): Modeline "1280x1024"  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync

The (D) means doublescan mode, which too many monitors don't support (or get confused by how G80 cards do it), so we turned it off.  The 2.1.6 means you're running an old version of the nv driver.

Both of these issues are fixed by xorg-x11-drv-nv-2.1.12-2.el5, which is included in snap3 and later.

*** This bug has been marked as a duplicate of bug 466347 ***
Comment 14 Larry Troan 2008-11-20 09:40:53 EST
VERIFIED that fix is in RHEL5.3 snapshot3 (20081113.1 ISO). Will post in bug 466347 as well.

Note You need to log in before you can comment on or make changes to this bug.