This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472090 - /etc/init.d/clvmd points to /usr/sbin for LVM tools
/etc/init.d/clvmd points to /usr/sbin for LVM tools
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2-cluster (Show other bugs)
10
All Linux
high Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 12:41 EST by John Ruemker
Modified: 2008-12-09 06:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 06:31:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ruemker 2008-11-18 12:41:37 EST
Description of problem: The clvmd init script in F10 Rawhide looks for the lvm tools (lvdisplay, vgchange, etc) in /usr/sbin as opposed to /sbin.  This results in a failure when trying to start the service, although clvmd actually does get started

Version-Release number of selected component (if applicable): lvm2-cluster-2.02.39-6.fc10.x86_64

How reproducible: Always

Steps to Reproduce:
1. # service clvmd start
  
Actual results: clvmd starts but the service reports 

    Activating VGs: /etc/init.d/functions: line 499: /usr/sbin/vgchange: No such file or directory
                                                           [FAILED]

Expected results: clvmd should start and the service should report "OK"
Comment 1 Alasdair Kergon 2008-11-18 13:20:59 EST
Hmmm.  I wonder if that was caused by the changes to work around the bug in rpm, or if it goes back longer.

Anyway, let's keep these out of /usr now - I'll update the script.
Comment 2 Alasdair Kergon 2008-11-19 15:20:23 EST
Please test Package: lvm2-2.02.39-7.fc10 Tag: dist-f10-updates-candidate
Comment 3 Fedora Update System 2008-11-19 15:28:24 EST
lvm2-2.02.39-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lvm2-2.02.39-7.fc10
Comment 4 John Ruemker 2008-11-20 16:03:35 EST
That fixed it.  Thanks
Comment 5 Fedora Update System 2008-11-22 11:48:47 EST
lvm2-2.02.39-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lvm2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-9969
Comment 6 Bug Zapper 2008-11-26 00:34:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora Update System 2008-12-09 06:31:21 EST
lvm2-2.02.39-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.