Bug 472093 - Incorrect openoffice.org-core dependency
Incorrect openoffice.org-core dependency
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org-voikko (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Ville-Pekka Vainio
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 13:08 EST by Ville-Pekka Vainio
Modified: 2014-01-21 18:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 21:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug report from pirut (672 bytes, application/octet-stream)
2009-11-09 14:04 EST, Dianne Spencer
no flags Details

  None (edit)
Description Ville-Pekka Vainio 2008-11-18 13:08:55 EST
(It's a bit weird making a bug report against my own package, but I'd like to have Caolán's input to the issue as well)

Description of problem:
I've received reports from Linpus Linux Lite users that they can't install openoffice.org-voikko. The distribution is based on Fedora 8 and I can reproduce the problem in a virtual machine with a Fedora 8 default DVD installation which isn't updated. There's a unopkg problem of some sort with openoffice.org 2.3.0-6.12.

Version-Release number of selected component (if applicable):
openoffice.org-voikko-2.2-2
openoffice.org 2.3.0-6.12

How reproducible:
Always

Steps to Reproduce:
1. Take a Fedora 8 default DVD install with no updates applied
2. Update fedora-release (but nothing else)
3. Try to install openoffice.org-voikko
  
Actual results:
"ERROR: unexpected option --link!
       Use unopkg --help (short -h) to print all options."
Because unopkg bails out, openoffice.org-voikko isn't installed into openoffice.org.

Expected results:
openoffice.org-voikko should be installable in a Fedora 8 installation with only the new fedora-release and no other updates. If this means bumping the openoffice.org-core Requires in openoffice.org-voikko, it should be done.

Caolán, can you give "educated guesses" as to why --link isn't working? I thought openoffice.org 2.3.0-6.12 had --link support in unopkg. According to koji 2.3.0-6.13 has had a fix for "rhbz#440650 mktemp has no --tmpdir on F-8", could this bug cause the unopkg shell script to call the unopkg binary with invalid options?

https://fedoraproject.org/wiki/Packaging/OpenOffice.orgExtensions says to Require 2.3.0-6.12 so if this bug can't be reproduced with later openoffice.org versions, the Requires of the extensions should probably be changed.
Comment 1 Ville-Pekka Vainio 2008-11-18 13:48:46 EST
I'm sorry, I didn't list the correct dependencies here and I'm beginning to think we've hit an RPM bug here or something.

Let's take a look at the packages and their versions again:

[root@localhost ~]# rpm -q openoffice.org-voikko
openoffice.org-voikko-2.2-2.fc8

That's ok, it's the newest openoffice.org-voikko I've shipped as an update to F-8.


[root@localhost ~]# rpm -q --requires openoffice.org-voikko
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
libc.so.6  
libc.so.6(GLIBC_2.1.3)  
libgcc_s.so.1  
libgcc_s.so.1(GCC_3.0)  
libm.so.6  
libstdc++.so.6  
libstdc++.so.6(CXXABI_1.3)  
libstdc++.so.6(CXXABI_1.3.1)  
libstdc++.so.6(GLIBCXX_3.4)  
libuno_cppu.so.3  
libuno_cppu.so.3(UDK_3.1)  
libuno_cppu.so.3(UDK_3_0_0)  
libuno_cppuhelpergcc3.so.3  
libuno_cppuhelpergcc3.so.3(UDK_3_0_0)  
libuno_sal.so.3  
libuno_sal.so.3(UDK_3_0_0)  
libvoikko.so.1  
openoffice.org-core >= 2.3.0-6.12
openoffice.org-core >= 2.3.0-6.12
openoffice.org-core >= 2.3.0-6.12
openoffice.org-core >= 2.3.0-6.12
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)

This seems ok to me as well, the package is requiring at least 2.3.0-6.12 as instructed on https://fedoraproject.org/wiki/Packaging/OpenOffice.orgExtensions


But now it gets interesting:
[root@localhost ~]# rpm -q openoffice.org-core
openoffice.org-core-2.3.0-6.6.fc8

So openoffice.org-voikko has the following Requires:
Requires(pre):    openoffice.org-core >= 2.3.0-6.12
Requires(post):   openoffice.org-core >= 2.3.0-6.12
Requires(preun):  openoffice.org-core >= 2.3.0-6.12
Requires(postun): openoffice.org-core >= 2.3.0-6.12

But for some reason RPM won't take those into consideration when it's installing openoffice.org-voikko.
Comment 2 Ville-Pekka Vainio 2008-11-18 14:04:04 EST
The RPM and Yum versions:

RPM: 4.4.2.2-3.fc8
Yum: 3.2.7-1.fc8

I also updated them both, but they still won't require the correct openoffice.org-core version, the updated versions:

RPM: 4.4.2.2-7.fc8
Yum: 3.2.19-3.fc8


Caolán (or anyone else reading this bug report for that matter), would this bug be worth reassigning to the RPM or the Yum developers and if so, which?

I think I could add Requires: openoffice.org-core >= 2.3.0-6.13 to openoffice.org-voikko in F-8, I bet that would work, but the OpenOffice Extension Guidelines may still need updating to prevent this from happening for other extensions.
Comment 3 Ville-Pekka Vainio 2008-11-18 16:07:21 EST
I'll assign this bug to yum for now, RPM might also be the right component, but there's definitely something weird going on with package management in this case.

I tried to make the problematic openoffice.org-core requirement more obvious by adding Requires: openoffice.org-core >= 2.3.0-6.13 to the spec file. This version of the SRPM and the spec file are at
 - http://vpv.fedorapeople.org/misc/rhbz-472093/openoffice.org-voikko-2.2-3.fc8.src.rpm
 - http://vpv.fedorapeople.org/misc/rhbz-472093/openoffice.org-voikko.spec

So now I have a package which has
BuildRequires:    openoffice.org-sdk >= 2.3.0-6.13
BuildRequires:    libvoikko-devel >= 1.5
Requires:         openoffice.org-core >= 2.3.0-6.13
Requires(pre):    openoffice.org-core >= 2.3.0-6.13
Requires(post):   openoffice.org-core >= 2.3.0-6.13
Requires(preun):  openoffice.org-core >= 2.3.0-6.13
Requires(postun): openoffice.org-core >= 2.3.0-6.13

I tried to install that package with only the Fedora 8 GA "fedora" repository available, which has openoffice.org-core-2.3.0-6.6.fc8, which should be too old for the Requires, but:

[root@localhost i386]# yum --disablerepo updates-newkey --nogpgcheck localinstall openoffice.org-voikko-2.2-3.fc8.i386.rpm 
Setting up Local Package Process
Examining openoffice.org-voikko-2.2-3.fc8.i386.rpm: openoffice.org-voikko-2.2-3.fc8.i386
Marking openoffice.org-voikko-2.2-3.fc8.i386.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package openoffice.org-voikko.i386 0:2.2-3.fc8 set to be updated
--> Processing Dependency: openoffice.org-core >= 2.3.0-6.13 for package: openoffice.org-voikko
--> Processing Dependency: openoffice.org-core >= 2.3.0-6.13 for package: openoffice.org-voikko
--> Processing Dependency: openoffice.org-core >= 2.3.0-6.13 for package: openoffice.org-voikko
--> Processing Dependency: openoffice.org-core >= 2.3.0-6.13 for package: openoffice.org-voikko
--> Processing Dependency: openoffice.org-core >= 2.3.0-6.13 for package: openoffice.org-voikko
--> Processing Dependency: libuno_cppu.so.3 for package: openoffice.org-voikko
--> Processing Dependency: libuno_cppu.so.3(UDK_3.1) for package: openoffice.org-voikko
--> Processing Dependency: libuno_cppu.so.3(UDK_3_0_0) for package: openoffice.org-voikko
--> Processing Dependency: libuno_cppuhelpergcc3.so.3 for package: openoffice.org-voikko
--> Processing Dependency: libuno_cppuhelpergcc3.so.3(UDK_3_0_0) for package: openoffice.org-voikko
--> Processing Dependency: libuno_sal.so.3 for package: openoffice.org-voikko
--> Processing Dependency: libuno_sal.so.3(UDK_3_0_0) for package: openoffice.org-voikko
--> Running transaction check
---> Package openoffice.org-core.i386 1:2.3.0-6.6.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                    Arch      Version              Repository     Size 
================================================================================
Installing:
 openoffice.org-voikko      i386      2.2-3.fc8            openoffice.org-voikko-2.2-3.fc8.i386.rpm
                                                                           45 k
Installing for dependencies:
 openoffice.org-core        i386      1:2.3.0-6.6.fc8      fedora          82 M

Transaction Summary
================================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 82 M
Is this ok [y/N]: y
Downloading Packages:
openoffice.org-core-2.3.0 100% |=========================|  82 MB    05:36     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : openoffice.org-core                               [1/2] 
  Installing     : openoffice.org-voikko                             [2/2] 

ERROR: unexpected option --link!
       Use unopkg --help (short -h) to print all options.

Installed: openoffice.org-voikko.i386 0:2.2-3.fc8
Dependency Installed: openoffice.org-core.i386 1:2.3.0-6.6.fc8
Complete!

So the installation succeeds even though a too old version of the dependency is available. Notice how yum prints "Processing Dependency: openoffice.org-core >= 2.3.0-6.13" but still accepts 2.3.0-6.6.fc8.
Comment 4 seth vidal 2008-11-18 16:17:15 EST
If you change the require to requires openoffice.org-core >= 1:2.3.0-6.13

does it do more of the right thing?

b/c as you have it above I'm reasonably certain that the 1-epoch makes yum see 2.3.0-6.6.fc8 as > than 2.3.0-6.13 w/o an epoch.
Comment 5 Fedora Update System 2008-11-18 17:34:27 EST
openoffice.org-voikko-2.2-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/openoffice.org-voikko-2.2-3.fc8
Comment 6 Ville-Pekka Vainio 2008-11-18 17:41:16 EST
Thanks Seth, that was actually the problem. I've built openoffice.org-voikko-2.2-3.fc8 which should fix this bug.

Caolán, do you think https://fedoraproject.org/wiki/Packaging/OpenOffice.orgExtensions needs an update to mention the need of the epoch or does it even matter anymore as Fedora 8 will be EOL soon and all later releases should have unopkg --link support anyway?

(I'll try to assign this bug back to openoffice.org-voikko and improve the description a bit as this was my packaging bug after all. Bodhi should close this once the bugfix package is in F8 stable updates.)
Comment 7 Caolan McNamara 2008-11-18 17:56:54 EST
The openoffice.org-core >= 2.3.0-6.12 was explicitly mentioned in those pages because earlier ones didn't have the -link support (and other goodies that make extentions as rpms reliable). I guess I cocked-up and didn't consider the epoch issue. Unfortunately it's sort of tricky to get a wiki page modified once it has been accepted into the fedora process as it gets locked down and it becomes fairly opaque to modify. I'll ping spot about it as he helped out the last time.
Comment 8 Fedora Update System 2008-11-19 09:45:32 EST
openoffice.org-voikko-2.2-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org-voikko'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-9691
Comment 9 Bug Zapper 2008-11-26 06:19:16 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2008-11-26 21:13:02 EST
openoffice.org-voikko-2.2-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Dianne Spencer 2009-11-09 14:04:03 EST
Created attachment 368271 [details]
bug report from pirut
Comment 12 Ville-Pekka Vainio 2009-11-09 16:00:34 EST
(In reply to comment #11)
> Created an attachment (id=368271) [details]
> bug report from pirut  

This Python traceback seems to have nothing to do with openoffice.org-voikko.

Note You need to log in before you can comment on or make changes to this bug.