Bug 472103 - Remove ImageMagick dep
Remove ImageMagick dep
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libfprint (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2008-11-18 14:16 EST by Bastien Nocera
Modified: 2009-07-21 09:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 09:12:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
0001-Add-gdk-pixbuf-support.patch (7.26 KB, patch)
2008-11-18 14:16 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2008-11-18 14:16:52 EST
Created attachment 323947 [details]
0001-Add-gdk-pixbuf-support.patch

# FIXME remove the ImageMagick dependency when we either have the
# gdk-pixbuf support merged, or disable the driver that requires it (F10)
BuildRequires:  libusb1-devel ImageMagick-devel glib2-devel openssl-devel 

I attached the patch I sent to Daniel to add gdk-pixbuf support. Apparently, it might need more testing. If that's not fixed by F11, we should disable the (quite broken anyway) aes4000 driver.
Comment 1 Pierre-YvesChibon 2008-11-19 09:13:33 EST
Thanks for the heads up and the update on to the git version.

You finally know that software better than I do, so feel free to change what's needed when it's needed.

Thanks
Comment 2 Bug Zapper 2008-11-26 00:34:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-06-09 05:53:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matthias Clasen 2009-07-18 03:37:11 EDT
Bastien, can we please get this resolved for F12 ? This currently pulls ImageMagick onto the live cd, which costs us 6M.
Comment 5 Bastien Nocera 2009-07-18 07:15:00 EDT
Can't solve it for F12 unless Daniel Drake takes a look at it. The problem is that we can't just use gdk-pixbuf to resize the image. ImageMagick's algorithm will not destroy, but enhance the minutia available. We don't know whether gdk-pixbuf would do the same.
Comment 6 Matthias Clasen 2009-07-18 17:14:11 EDT
How about the fallback plan mentioned earlier ?

 " If that's not fixed by F11, we should disable the
(quite broken anyway) aes4000 driver. "
Comment 7 Bastien Nocera 2009-07-18 19:34:18 EDT
I guess I'll neeta it more closely then :)
Comment 8 Bastien Nocera 2009-07-21 09:12:48 EDT
Switched to gdk-pixbuf in:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1489434

Sending mails to fedora-devel and the fprint lists.

Note You need to log in before you can comment on or make changes to this bug.