Bug 472104 - /etc/init.d/kdump: line 134: [: too many arguments
/etc/init.d/kdump: line 134: [: too many arguments
Status: CLOSED DUPLICATE of bug 471306
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 14:29 EST by Charlotte Richardson
Modified: 2009-09-06 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 15:16:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlotte Richardson 2008-11-18 14:29:43 EST
Description of problem:
Any attempt to start or restart service kdump gets
/etc/init.d/kdump: line 134: [: too many arguments

Version-Release number of selected component (if applicable):
kdump-kexec from RHEL5.3-snap2

How reproducible:
Always

Steps to Reproduce:
1. touch /etc/kdump.conf
2. service kdump restart
  
Actual results:
/etc/init.d/kdump: line 134: [: too many arguments

Expected results:
Should work.

Additional info:
The line being complained about in /etc/init.d/kdump (line 134) is:

if [ -n "$FORCE_REBUILD" -a $modified_files!=" "]

It should be:
if [ -n "$FORCE_REBUILD" -a "$modified_files"!=" "]

which works fine.
Comment 1 Neil Horman 2008-11-18 15:16:17 EST

*** This bug has been marked as a duplicate of bug 471306 ***

Note You need to log in before you can comment on or make changes to this bug.