Bug 472105 - Cannot run JTZU updates with java-1.4.2-ibm SR12
Cannot run JTZU updates with java-1.4.2-ibm SR12
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-ibm (Show other bugs)
ppc Linux
medium Severity medium
: rc
: ---
Assigned To: jiri vanek
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2008-11-18 14:49 EST by Lillian Angel
Modified: 2010-11-16 03:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-11-16 03:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
root.log - in case link provided does not work (78.48 KB, text/plain)
2008-11-19 16:39 EST, Lillian Angel
no flags Details
ppc build.log - in case not visible through provided link (25.32 KB, application/octet-stream)
2008-11-19 16:40 EST, Lillian Angel
no flags Details

  None (edit)
Description Lillian Angel 2008-11-18 14:49:29 EST
Description of problem:

When trying to run the jtzu-1.6.8f update on the specified JDK, it fails. (only on ppc, RHEL-4 and RHEL-3)

Version-Release number of selected component (if applicable):

java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)
Classic VM (build 1.4.2, J2RE 1.4.2 IBM build cxia32142-20080923 (SR12) (JIT enabled: jitc))

How reproducible:
Every time

Steps to Reproduce:
1. Unzip java-1.4.2-ibm SR12 ppc tarball
2. set JTZU_JRE_PATH=/path/to/IBMJava2-ppc-142/jre
  cd jtzu
  unzip jtzu-1.6.8f.zip
  cp -a runjtzuenv.sh runjtzuenv.sh.orig
  echo $JTZU_JRE_PATH > SDKList.txt
  cat > runjtzuenv.sh << EOF
  chmod +x runjtzu.sh
Actual results:

Build log can be found here for the next 24 hours: https://brewweb.devel.redhat.com/getfile?taskID=1578394&name=build.log

*********** Welcome to the IBM Time Zone Update Utility for Java (JTZU) Version 1.6.8c ***********
JTZU Home: /builddir/build/BUILD/IBMJava2-ppc-142/jtzu
Set the variables using the script /builddir/build/BUILD/IBMJava2-ppc-142/jtzu/runjtzuenv.sh
Launching the Java Time Zone Updater Tool.
JVMLH057: detectNPTL cannot create thread.
./runjtzu.sh: line 47: 29898 Aborted                 "$JAVA_HOME/bin/java" -cp "$JTZU_HOME/JTZU.jar" -Dnogui=$NOGUI -Ddiscoveronly=$DISCOVERONLY -Dsilentpatch=$SILENTPATCH -Dbackwardcompatibility=$BACKWARDCOMPATIBILITY JTZUMain
error: Bad exit status from /var/tmp/rpm-tmp.64915 (%prep)

Expected results:

JTZU updates the JDK without failing.

Additional info:

This only happens on ppc architectures.
Comment 1 IBM Bug Proxy 2008-11-19 16:00:44 EST

According to
the message being displayed before the JVM ends:

"JVMLH057 detectNPTL cannot create thread."

has the following explanation:

"The Native Posix Thread Library (NPTL) is unable to create the thread. The detectNPTL function detects whether NPTL or the Linux Thread Library is used."

Is it possible to get the jtzu-1.6.8f.zip to attempt to recreate this within IBM? Does it require any tools that should be installed with a RHEL 4.7 ppc64 system (that hopefully come with RHEL)?

Does the script work fine using the SR11 version of Java 1.4.2 ? Does the problem recreate itself on RHEL 4.7 (I don't have any early development releases of 4.8 or 4.9 available to me).
Comment 2 Lillian Angel 2008-11-19 16:36:45 EST
Yes, this worked fine with SR11. It seems that all versions of jtzu-1.6.8(a-f) are failing on ppc and ppc64. The problem is reproducible on RHEL 4.7.


You can check out the root.log to see what versions of the tools are installed:

I believe the only one required for the jtzu tool is compat-libstd-c++, but there may be others that are pulled indirectly.
Comment 3 Lillian Angel 2008-11-19 16:39:57 EST
Created attachment 324098 [details]
root.log - in case link provided does not work
Comment 4 Lillian Angel 2008-11-19 16:40:54 EST
Created attachment 324099 [details]
ppc build.log - in case not visible through provided link
Comment 5 IBM Bug Proxy 2008-11-19 18:01:07 EST
Thanks. I downloaded the jtzu-1.6.8f from http://www.ibm.com/developerworks/java/jdk/dst/index.html and have the IBMJava2-SDK-1.4.2-12.0.ppc64.tgz to install on a RHEL 4.7 ppc64 system to try and recreate it in-house for the Java folks to take a look at.
Comment 6 IBM Bug Proxy 2008-11-19 22:01:02 EST

I set up a ppc64 host with RHEL 4.7 and with the unpacked Java 1.4.2 SR12 ran tried to recreate the problem but instead I got:

[root@gekko-lp4 jtzu]# echo $JTZU_JRE_PATH
[root@gekko-lp4 jtzu]# ./runjtzu.sh
*********** Welcome to the IBM Time Zone Update Utility for Java (JTZU) Version 1.6.8f ***********
JTZU Home: /root/jtzu
Set the variables using the script /root/jtzu/runjtzuenv.sh
Launching the Java Time Zone Updater Tool.

*********** Command-Line 'Patch' Mode Started ***********
'Patch' Mode:
In this mode, the tool patches each of the Java installations listed in SDKList.txt with the new time zone information.

*********** WARNING MESSAGE ***********
Warning - Applying IBM product maintenance which contains down level time zone data will remove the updates applied by this tool.  In such cases you will need to re-run this tool to restore the time zone data to the latest level. Updates made to the Java time zone data by this tool are not managed by any of the formal change control mechanisms for servicing IBM software products.

SDKList.txt file exists
List of SDKs from the file /root/jtzu/TimeZoneInfo/../SDKList.txt

The tool will now update the SDK/JREs detected with new timezone information, if applicable.

Existing time zone information is old, the Java needs time zone update.
The tool will now update the Java with the new timezone information...
The Java installation is updated with the new timezone information !

The following SDK/JREs were updated with the new timezone information.


I forgot to mention that I strayed a bit from the recreation instructions. That is, wherever there was an environment variable to be set I used export to make it visible, e.g. export JTZU_JRE_PATH=/path/to/IBMJava2-ppc-142/jre and the variables in runjtzuenv.sh
Comment 7 Lillian Angel 2008-11-20 08:32:51 EST
It must be an issue with RHEL-4.8pre then. I will have to narrow it down to the dependency causing the problem.

Thanks, I will keep you updated.
Comment 9 Lillian Angel 2009-01-12 13:07:29 EST
This is coming up as an issue for java-1.5.0-ibm SR9 and java-1.6.0-ibm SR3, as well. only on RHEL-4. I cannot reproduce it locally...
Comment 10 Lillian Angel 2009-01-12 13:11:26 EST
happens with jtzu1.6.8i and jtzu1.6.8f
Comment 12 Radek Bíba 2010-06-30 01:59:59 EDT
No, not fixed in the current release. Reopening.

Note You need to log in before you can comment on or make changes to this bug.