Bug 472121 - NIS host resolution fails for some host entries
NIS host resolution fails for some host entries
Status: CLOSED DUPLICATE of bug 473073
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 15:39 EST by Jimmy Dorff
Modified: 2008-12-01 11:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 11:08:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jimmy Dorff 2008-11-18 15:39:28 EST
Description of problem:
When resolving hosts via NIS, there seems to be a problem resolving if the host's map entry contains multiple names for the host.

Version-Release number of selected component (if applicable):
glibc-2.9-2.i686

How reproducible:
You will need a working NIS domain. I have the following:
$ grep hosts /etc/nsswitch.conf 
hosts:      files nis dns

Steps to Reproduce:
1. 
Find a host with multiple hostnames in the NIS host map:
$ ypmatch monserv hosts
152.3.182.15		monserv.phy.duke.edu monserv loghost
Observe that name lookups fail for that host (just using wget as an example app since it's verbose):
$ wget monserv
Resolving monserv... failed: Name or service not known.
$ wget loghost
Resolving loghost... failed: Name or service not known.

Find a host with a simple NIS host entry:
$ ypmatch rhic00 hosts
152.3.182.72		rhic00.phy.duke.edu rhic00
Observe that it resolves correctly:
$ wget rhic00
Resolving rhic00... 152.3.182.72

2.
Disable NIS host resolution and observe that all hosts now work using DNS:
$ grep hosts /etc/nsswitch.conf
hosts:      files dns
$ wget monserv
Resolving monserv... 152.3.182.15
$ wget rhic00
Resolving rhic00... 152.3.182.72

Actual results:
NIS names resolution fails for multi name host entries

Expected results:
NIS resolution should work for multi name hosts in the same manner that the local file "/etc/hosts" does.

Additional info:
ypbind-1.20.4-8.fc10.i386
yp-tools-2.9-4.i386
kernel-2.6.27.5-113.fc10.i686
SELINUX=disabled
Comment 1 Bug Zapper 2008-11-26 00:34:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Emmanuel Thomé 2008-11-28 04:13:31 EST
Jimmy, could you check that this is indeed a duplicate of bug 473073 ?
Comment 3 Jimmy Dorff 2008-12-01 11:07:51 EST
Yes, this bug is the same as bug 473073
Comment 4 Jimmy Dorff 2008-12-01 11:08:59 EST

*** This bug has been marked as a duplicate of bug 473073 ***

Note You need to log in before you can comment on or make changes to this bug.