Bug 472151 - rpm verify fails after a fresh install
rpm verify fails after a fresh install
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Panu Matilainen
Petr Sklenar
:
: 508855 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 19:06 EST by Bryan Mason
Modified: 2009-10-26 18:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch adapted from upstream (only the line numbers changed). (590 bytes, patch)
2008-11-18 19:06 EST, Bryan Mason
no flags Details | Diff

  None (edit)
Description Bryan Mason 2008-11-18 19:06:14 EST
Created attachment 323985 [details]
Proposed patch adapted from upstream (only the line numbers changed).

Description of problem:

    Running "rpm -Va" on a freshly-installed x86_64 system reports
    thousands of files with mtimes that differ from the original
    package.  This pretty much makes rpm verification useless.

Version-Release number of selected component (if applicable):

    rpm-4.4.2.3-7.el5

How reproducible:

    Every time.

Steps to Reproduce:

    1. Install new x86_64 system.
    2. run "rpm -Va"
  
Actual results:

    Many files differ from the ones in the RPM package.  Most of them
    differ only in their mtime and are the ones that belong to
    multiarch packages.

Expected results:

    "rpm -Va" should list only the files that have actually changed

Additional info:

This is one of the complaints put forth in Bug 426672.  This has also
been addressed in upstream rpm:

http://rpm.org/gitweb?p=rpm.git;a=commit;h=9646a117c916022067fd07e4f6a7e25c5c9814de
Comment 1 Panu Matilainen 2008-11-19 01:55:08 EST
Backporting the fix is easy, devel ack for 5.4.
Comment 5 Panu Matilainen 2009-06-30 05:50:26 EDT
*** Bug 508855 has been marked as a duplicate of this bug. ***
Comment 6 Chris Ward 2009-07-03 14:13:48 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 8 Petr Sklenar 2009-07-07 09:37:34 EDT
adding QAkeyword RHTSinProgress:

* rhts test created:
  -- /CoreOS/rpm/Regression/bz426672-Make-rpm-V-be-useful-again
  -- test fail due to bug 506922 : there are many different /usr/shared docs files, that's why fails
        
rhts results:
 http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=70559
x86_64.log:
 http://rhts.redhat.com/testlogs/70559/223769/1832406/TESTOUT.log
expected differs + md5 docs differs
Comment 10 errata-xmlrpc 2009-09-02 07:40:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1371.html

Note You need to log in before you can comment on or make changes to this bug.