Bug 47218 - Do a dependency check after video card selection
Do a dependency check after video card selection
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-03 19:46 EDT by Sam Varshavchik
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 10:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2001-07-03 19:46:21 EDT
Description of Problem:

In the text mode install, the video card detection screen appears out of
sequence in the middle of package selection.

How Reproducible:

Always.

Steps to Reproduce:

Choose a New Install, select major installation components, opt in to
adjust individual packages.  Deliberately select some packages that have a
dependency on some other packages that you haven't selected.

Actual Results:

On the next screen, the installer will tell you what video card it
autodetected.

On the subsequent screen, the installer will complain about unresolved
dependencies.

Expected Results:

Video card autodetection appears to be out of place.  It should happen
either before the business with the package selection is squared away with,
or after everything concerning package selection has been done, but not in
the middle of the process, like that.  Very confusing.

Additional Information:
Comment 1 Michael Fulbright 2001-07-05 11:38:50 EDT
We ask because if you have a video card which needs a XFree86 3.x.x we need
to know so we add it to the list of packages to be installed. I will look at
moving it after the dependencies, at least that won't be quite as confusing.
Comment 2 Michael Fulbright 2001-07-09 22:27:48 EDT
I've moved it now - now need to run dependencies again after selection to be
sure all packages we need for X server are in list to be installed.
Comment 3 Michael Fulbright 2001-08-07 10:53:39 EDT
Matt would you pretty please look at this for me?
Comment 4 Michael Fulbright 2001-08-30 15:42:54 EDT
We've handled dependcies as required.

Note You need to log in before you can comment on or make changes to this bug.