Bug 472188 - Xen PV guest doesn't start after reboot
Xen PV guest doesn't start after reboot
Status: CLOSED DUPLICATE of bug 471588
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 04:27 EST by Alexander Todorov
Modified: 2009-12-14 16:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 06:19:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-11-19 04:27:39 EST
Description of problem:
Issuing a reboot command in Xen PV guest will reboot the guest OS. Default config is dom0 to restart the domU and reconnect the graphical VNC console. However with latest 5.3 nightly build this doesn't happen.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-123.el5
xen-3.0.3-75.el5


How reproducible:
Always

Steps to Reproduce:
1. Install dom0 with 1113.1 build (i386)
2. Install PV domU with 1118.nightly build
3. Log in as root in domU and type 'reboot'
  
Actual results:
domU goes down but never goes up again

Expected results:
domU powers up after reboot

Additional info:
This is a regression from 5.2 where a reboot command restarts the domU and dom0 successfully reconnects the graphical console.
Comment 2 Alexander Todorov 2008-11-19 04:30:44 EST
my domU config file


name = "s3"
uuid = "28190303-6eb3-476e-64c4-3b28f487d315"
maxmem = 512
memory = 512
vcpus = 1
bootloader = "/usr/bin/pygrub"
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
vfb = [ "type=vnc,vncunused=1,keymap=en-us" ]
disk = [ "tap:aio:/var/lib/xen/images/s.img,xvda,w" ]
vif = [ "mac=00:16:3e:3b:2a:f6,bridge=xenbr0" ]
Comment 3 Daniel Berrange 2008-11-19 06:19:30 EST

*** This bug has been marked as a duplicate of bug 471588 ***

Note You need to log in before you can comment on or make changes to this bug.