Bug 472263 - fixup distribution of auto-generated mime-data
fixup distribution of auto-generated mime-data
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdesklets (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luya Tshimbalanga
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 12:30 EST by Christian Krause
Modified: 2008-12-11 02:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 23:14:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for gdesklets.spec to fix the problem (875 bytes, patch)
2008-11-19 12:30 EST, Christian Krause
no flags Details | Diff

  None (edit)
Description Christian Krause 2008-11-19 12:30:40 EST
Created attachment 324079 [details]
patch for gdesklets.spec to fix the problem

The gdesklets rpm packages contains a lot of auto-generated mime data. This
causes a failure of the integrity check:

rpm -V gdesklets
S.5....T    /usr/share/mime/generic-icons
S.5....T    /usr/share/mime/globs2
.......T    /usr/share/mime/icons
S.5....T    /usr/share/mime/treemagic
S.5....T    /usr/share/mime/types


These files are auto-generated during the installation of the package via
"update-mime-database" and they should not be distributed within the package itself.

I've attached a small patch to the spec file which fixes the problem.
Comment 1 Bug Zapper 2008-11-26 00:37:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Update System 2008-11-28 06:51:48 EST
gdesklets-0.36.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gdesklets-0.36.1-3.fc10
Comment 3 Fedora Update System 2008-11-28 06:51:53 EST
gdesklets-0.36.1-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/gdesklets-0.36.1-3.fc8
Comment 4 Fedora Update System 2008-11-28 06:51:56 EST
gdesklets-0.36.1-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gdesklets-0.36.1-3.fc9
Comment 5 Fedora Update System 2008-12-02 20:17:09 EST
gdesklets-0.36.1-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdesklets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10561
Comment 6 Fedora Update System 2008-12-02 20:19:29 EST
gdesklets-0.36.1-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update gdesklets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10588
Comment 7 Fedora Update System 2008-12-02 20:19:39 EST
gdesklets-0.36.1-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update gdesklets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-10592
Comment 8 Christian Krause 2008-12-03 05:29:25 EST
I've tested gdesklets-0.36.1-3.fc10.i386 and the problem is fixed - Thanks!
Comment 9 Luya Tshimbalanga 2008-12-03 23:17:28 EST
No problem, I am closing this bug.
Comment 10 Fedora Update System 2008-12-11 02:55:35 EST
gdesklets-0.36.1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-12-11 02:57:22 EST
gdesklets-0.36.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-12-11 02:59:31 EST
gdesklets-0.36.1-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.