Bug 472283 - keyboard repeat toggles between unidirectional and off
keyboard repeat toggles between unidirectional and off
Status: CLOSED DUPLICATE of bug 449672
Product: Fedora
Classification: Fedora
Component: synergy (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 14:39 EST by Doug Maxey
Modified: 2009-01-02 11:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-02 11:17:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Maxey 2008-11-19 14:39:23 EST
Description of problem:
On a t61p with the touchpad disabled, the 'repeat key' function toggles between
being completely off, or with an 'xset r on' becomes all directional for a few
seconds before going back to being off or unidirectional.

Repeated 'xset r on' and 'xset r off' seem to toggle the behavior - regardless of which is selected, there are a few seconds of all directional repeats, then
the repeating becomes uni-directional or stops completely.  Most of the time
it appears to be ok to the right and up.  Down and left seem to be the first to stop responding.
Comment 1 Doug Maxey 2008-11-19 16:57:20 EST
gah.  When using the native keyboard, will retract all of what I stated above.  Using the native keyboard works fine.

However, the above does hold entirely true when using the synergy client and the client has focus.  Guess I have become so used to it that I never think about it.

Focusing on the synergy area, it also continously loses focus, but the majority of the time it does recover within 10 seconds or so.  Otherwise, I have to restart the client on the target.
Comment 2 Bug Zapper 2008-11-26 00:37:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Michael Semcheski 2008-12-03 12:57:41 EST
Not sure if this is a seperate bug, but what I'm seeing is very close.

I don't notice a change in behavior with 'xset r on' and 'xset r off'.  Perhaps I'm not looking at the right behavior.

The only keys that don't seem to repeat are the down-arrow and left-arrow keys.  Up and right, as well as the letter and number keys repeat without an issue.

When synergyc is running and the client has focus, the down and left keys don't repeat, whether using the keyboard on the synergy server, or the USB keyboard physically plugged into the synergy client.  If the client does not have focus, the usb keyboard down and left keys repeat without issue.  And obviously, if you kill synergyc, the USB keyboard works without issue.

If numlock is off, the arrow keys on the number pad work OK with synergy.
Comment 4 Matthias Saou 2009-01-02 11:10:10 EST
Could this repeat problem be the one already reported in bug #449672?
Could the "loses focus, have to sait 10s" be the problem already reported in bug #469422?

You might want to check that second bug report. For the first one, it seems like a quite low-level issue I'm really not capable of taking care of, and the developers are not responsive...
Comment 5 Matthias Saou 2009-01-02 11:17:43 EST
Closing as duplicate of bug #449672. Check out that report for links to the upstream bug reports. Seems like the only workaround is the one you're already using, though.

*** This bug has been marked as a duplicate of bug 449672 ***

Note You need to log in before you can comment on or make changes to this bug.