Bug 472314 - System Freeze with ati radeon xpress 200m and xorg-x11-drv-ati >= 6.9.0-45
System Freeze with ati radeon xpress 200m and xorg-x11-drv-ati >= 6.9.0-45
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 18:43 EST by Florent Le Coz
Modified: 2008-12-14 09:45 EST (History)
7 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.9.0-58
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-27 08:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log, without any xorg.conf file (62.07 KB, text/plain)
2008-11-20 15:17 EST, Florent Le Coz
no flags Details
Xorg Backtrace 1 (1.78 KB, text/plain)
2008-11-23 14:20 EST, Phip
no flags Details
Xorg backtrace (7.04 KB, text/plain)
2008-11-23 14:32 EST, Florent Le Coz
no flags Details
Xorg Backtrace 2 (2.63 KB, text/plain)
2008-11-23 19:51 EST, Phip
no flags Details
Xorg Backtrace 3 (1.33 KB, text/plain)
2008-11-24 02:55 EST, Phip
no flags Details

  None (edit)
Description Florent Le Coz 2008-11-19 18:43:47 EST
Description of problem:
With Rawhide (f10) system completely freezes about 5 minutes after the boot.


Version-Release number of selected component (if applicable):
It happens since the xorg-x11-drv-ati-6.9.0-45, and still happens with the xorg-x11-drv-ati-6.9.0-54

It doesn't happen with xorg-x11-drv-ati-6.9.0-38


How reproducible:
always (after some time)


Steps to Reproduce:
1.just boot
2.wait
3.freeze
Comment 1 Matěj Cepl 2008-11-20 07:53:12 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

Of course, there is even newer xorg-x11-drv-ati available http://koji.fedoraproject.org/koji/buildinfo?buildID=70300

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Florent Le Coz 2008-11-20 15:17:02 EST
Created attachment 324230 [details]
log, without any xorg.conf file
Comment 3 Florent Le Coz 2008-11-20 15:20:26 EST
I had no xorg.conf file (it's a completely fresh fedora 10 install, updated), so I can only provide one log file.

louiz@myrtille ~> uname -a
Linux myrtille.localdomain 2.6.27.5-117.fc10.x86_64 #1 SMP Tue Nov 18 11:58:53 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

With the latest xorg-x11-drv-ati-6.9.0-55.fc10

I hope it will help identify the problem.
Comment 4 Matěj Cepl 2008-11-20 15:35:37 EST
I am not sure how much you are able to do in 5 minutes -- what exactly was going on in the moment of freeze? Have you managed to login into gdm?
Comment 5 Florent Le Coz 2008-11-20 17:07:37 EST
Yes, I was logged, I opened Gajim and Evolution, and then I frozed. (by doing nothing in particular, all softwares where completely launched)
Comment 6 Michal Schmidt 2008-11-21 10:51:04 EST
Is it really a complete freeze? Can you ssh into the machine in this state? If not, can you ping it? If not, does Alt+SysRq+B reboot it?
Comment 7 b.tataroiu 2008-11-21 11:43:13 EST
I have the same card and the same problem as him. For me it's a complete freeze, nothing works, not even alt+sysrq+b. There was one time when I actually managed to change to the virtual terminal as the mouse was beginning to tear, but upon trying to switch back to X it died.
Comment 8 Phip 2008-11-23 03:09:21 EST
I also have an xpress 200m and am having similar recurring freeze problems. I'm running a fresh (today) install from the 10pre live image.

I am able to ssh in after this happens -- until I kill the Xorg process. At that point it freezes completely and stops responding to pings.

I can generally predict when the freeze will occur. It seems to happen when something changes a graphics buffer very rapidly. The most notorious for me is doing a large yum search in a terminal program. ('yum search app' works well) As the results flood down the window, Xorg will freeze. This happens whether I am using metacity or openbox, and whether I'm using Gnome-terminal or XFCE's.

If I am advised of tests or checks that would be useful to do via ssh, I would be glad to take a sample.
Comment 9 Michal Schmidt 2008-11-23 07:36:27 EST
John B,
if ssh works for you, you can obtain a backtrace. Attach to the X server with gdb:
gdb -p $(pidof Xorg)
Then print the backtrace using the "bt" command. The backtrace will contain more information if you have relevant *-debuginfo packages installed.
Comment 10 Gerald Cox 2008-11-23 10:14:17 EST
472634 may be a duplicate - however in 472634 other processes continue to run, it is the display and keyboard/mouse which lock; not the entire system.  Are you able to press the power button on your machine to reboot the system?  Does using the "nomodeset" parameter circumvent the issue?
Comment 11 Florent Le Coz 2008-11-23 12:44:49 EST
The system is not completely frozen, because music still continues to play.
But I can't change the X server (alt+ctrl+F2 doesn't do anything) and the power button doesn't shutdown the computer. I have to force-shutdown by holding the power button.

(In reply to comment #9)
> John B,
> if ssh works for you, you can obtain a backtrace. Attach to the X server with
> gdb:
> gdb -p $(pidof Xorg)
> Then print the backtrace using the "bt" command. The backtrace will contain
> more information if you have relevant *-debuginfo packages installed.

I'll try to do this ASAP, if I can.
Comment 12 Phip 2008-11-23 14:20:04 EST
Created attachment 324440 [details]
Xorg Backtrace 1
Comment 13 Florent Le Coz 2008-11-23 14:32:45 EST
Created attachment 324441 [details]
Xorg backtrace

I think it lacks some debuginfo packages but I don't know exactly which one.
Comment 14 Phip 2008-11-23 19:51:10 EST
Created attachment 324449 [details]
Xorg Backtrace 2

This backtrace is similar, but different, from my first one. It happened with Pidgin in the foreground.

My traces seem to suggest a different problem from the one the OP, Florent le Coz, is experiencing. If instructed I'll be glad to create a new ticket.
Comment 15 Dave Airlie 2008-11-23 23:01:44 EST
I've just kicked off a new kernel build in koji.

kernel-2.6.27.5-123.fc10

it'll appear here when finished.

http://kojipkgs.fedoraproject.org/packages/kernel/2.6.27.5/123.fc10/

Can you install it and see if it helps?
Comment 16 Phip 2008-11-24 02:55:06 EST
Created attachment 324458 [details]
Xorg Backtrace 3

Using kernel-2.6.27.5-123.fc10 and xorg-x11-drv-ati-6.9.0-56.fc10, my system still freezes. The backtrace changed though, from my attachment 324440 [details] to resemble Florent le Coz's 324441.

I've found problem is not present with xorg-x11-drv-ati-6.9.0-38 for me either.
Comment 17 Florent Le Coz 2008-11-24 06:06:41 EST
I'll try the new build of the kernel latter on today.

I may be missing some debug-info packages, which one should I install to have the most usefull backtrace possible ? xorg-x1-drv-ati-debuginfo and kernel-debuginfo ? Nothing else ?
Comment 18 Matěj Cepl 2008-11-24 11:06:07 EST
(In reply to comment #17)
> I'll try the new build of the kernel latter on today.
> 
> I may be missing some debug-info packages, which one should I install to have
> the most usefull backtrace possible ? xorg-x1-drv-ati-debuginfo and
> kernel-debuginfo ? Nothing else ?

debuginfo-install xorg-x11-drv-ati xorg-x11-server-Xorg mesa kernel
Comment 19 Michal Schmidt 2008-11-24 11:54:28 EST
Bug 472536 is about similar symptoms on a bit different ATI hardware. The cause could be identical. In https://bugzilla.redhat.com/show_bug.cgi?id=472536#c7 I posted a workaround patch and a linked to a scratch build of the driver for testing.
Comment 20 Matěj Cepl 2008-11-24 20:25:24 EST
Reporter, does the package mentioned in comment 19 and https://bugzilla.redhat.com/show_bug.cgi?id=472536#c7 helps?
Comment 21 Dave Airlie 2008-11-25 01:45:50 EST
does xorg-x11-drv-ati -57 from koji help?

the backtraces will always be similiar, really all that is happening is the GPU has crashed and the driver is getting blocked waiting for it.
Comment 22 Phip 2008-11-25 13:20:34 EST
I still freeze with xorg-x11-drv-ati -57.
Comment 23 Bug Zapper 2008-11-26 00:38:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 24 Michal Schmidt 2008-11-26 04:43:24 EST
xorg-x11-drv-ati-6.9.0-58 from Koji fixed bug 472536 for me and Florent le Coz reported success too. Would other people seeing the freeze test it too please?
Comment 25 Florent Le Coz 2008-11-26 05:18:51 EST
As #472536 and this bug seem to describe the same issue (duplicate ?), I can tell here that this bug seems to be fixed by the xorg-x11-drv-ati-6.9.0-58 from Koji, like Michal Schmidt said.
Comment 26 Phip 2008-11-26 13:30:24 EST
drv-ati 58 has seemeed to fix it for me so far. Many thanks!
Comment 27 Matěj Cepl 2008-11-27 08:49:52 EST
Thanks for letting us know.
Comment 28 info 2008-12-11 11:22:18 EST
I still see that with xorg-x11-drv-ati-6.9.0-61.fc10.x86_64 and kernel-2.6.27-117

I use nomodeset in the kernel boot line. It happens both with and without, but with nomodeset it doesn't happen so frequently. 

I can't see any pattern when this happens. Sometimes it's when scrolling in konqueror, sometimes when working in console, sometimes when I'm not doing anything. system freezes completely, have to do a hard reset (with resulting data loss and often filesystem corruption).

Sometimes I get horizontal lines on the screen a few minutes before the crash, but not always.

This is on a Fujitsu-Siemens Amilo 1650G laptop, x86_64, with ATI Radeon Xpress 200M.

Note You need to log in before you can comment on or make changes to this bug.