Bug 472317 - Headphone sound stopped working
Headphone sound stopped working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: HardwareEnablement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 20:06 EST by Andre Costa
Modified: 2011-11-26 19:24 EST (History)
19 users (show)

See Also:
Fixed In Version: 2.6.27.12-78.2.8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:58:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hda-verb utility source code (9.57 KB, application/x-bzip)
2011-11-15 07:47 EST, Andre Costa
no flags Details

  None (edit)
Description Andre Costa 2008-11-19 20:06:14 EST
Description of problem: Headphone sound from front jack always worked on my system (since F8, F9 as well). However, it stopped working for some reason, probrably due to a recent kernel upgrade (I can't precise exactly when it stopped working, but I can say it's recente, less than a month). It's not a hardware issue, because headphone works on Windows XP (system is dual-boot).
I googled looking for some answers, and found out this message on LKML that seems to describe exactly what I'm experiencing:

http://lkml.org/lkml/2008/2/11/412

(message is from Feb 11, but this could be a regression)

I tried increasing channel count to 6, as suggested by this thread:

http://www.mail-archive.com/alsa-user@lists.sourceforge.net/msg23600.html

However, it did not work.

I found out that recent (> 1.0.17) ALSA versions include better ALC888 support, but since headphone worked with previous ALSA versions, I am inclined to blame kernel changes.

Running 'alsamixer -c 0' shows headphone as a toggle feature (as does volume control GUI), but changing it has no effect on sound whatsoever. I also tried unmuting and changing volume on all tracks, but it didn't work.

Version-Release number of selected component (if applicable):
kernel: 2.6.27.5-41.fc9.x86_64
alsa-lib-1.0.17-2.fc9.x86_64
alsa-plugins-pulseaudio-1.0.16-4.fc9.x86_64
pulseaudio-libs-0.9.10-2.fc9.x86_64

How reproducible: always


Steps to Reproduce:
1. play sound with any app (rhythmbox, totem etc.)
2.
3.
  
Actual results: front speakers play as expected, but headphone is mute


Expected results: sound would play on headphone as well


Additional info:
Some hardware info:

# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xa3220000 irq 22

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Comment 1 Andre Costa 2008-11-22 17:49:54 EST
It's definitely a bug with the latest kernel version: I just confirmed that headphone works with kernel 2.6.26.6-79.
Comment 2 Andre Costa 2008-11-23 09:15:58 EST
Additional info: the problem has been introduced with 2.6.27.* series (headphone doesn't work neither with 2.6.27.5-37 nor with 2.6.27.5-41).
Comment 3 Andre Costa 2008-12-11 13:37:05 EST
Problem persists on all F10 kernels (2.6.27.5-117 and 2.6.27.7-134). Is anyone investigating this?
Comment 4 Yaakov Nemoy 2009-01-01 22:05:13 EST
Confirmed on a dell vostro 1400

lspci
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Reverting to kernel 2.6.27.7-134 works for me.
Comment 5 Keith Williams 2009-01-02 05:30:34 EST
Indeed the 2.6.27.7-134 kernel works.

Gathered a list from fedoraforum.org and it seems that all is Intel chipset family related:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03) 

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Kind regards,
Comment 6 Yaakov Nemoy 2009-01-02 12:53:55 EST
I should  note that my comments apply to Fedora 10.
Comment 7 Alexander 2009-01-04 12:18:37 EST
On fedora 10 on my Dell XPS M1530 I've been having the same problem.

I also reported this to the alsa-dev mailinglist:
http://mailman.alsa-project.org/pipermail/alsa-devel/2008-December/013615.html


In kernel 2.6.27.9-159.fc10.i686 jacksense on the 2 outputs still works (sound of the laptop-speakers stop playing). And I can still switch the mic to output.


In kernel 2.6.27.7-134 the microphone-input and mic-as-out option do no longer work and jacksense is very buggie (only works when the jacks are slightly pulled out before put in again).


I hope this is helpfull for the devs working on this.
Comment 8 Enygma 2009-01-05 15:33:51 EST
Confirmed on Dell Inspiron 1520 since upgraded to Fedora 10.

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

$ lspci -n | grep 00:1b.0
00:1b.0 0403: 8086:284b (rev 02)

$ uname -r
2.6.27.9-159.fc10.i686

Please fix.

Thanks and good luck ;)
Comment 9 Andre Costa 2009-01-06 07:16:54 EST
Some additional info that might be helpful:

- microphone front jack works for me with 2.6.27.9-159
- I have similar problems on Windows XP: in order for the front headphone jack to work, I have to check a specific checkbox on Realtek's HD audio control panel. However, even though sound comes out on the front headphone jack for most apps (games, iTunes etc.), Skype can only use speakers for output.
Comment 10 Enygma 2009-01-06 07:31:59 EST
Mine works perfectly on XP and it also worked perfectly in Fedora 9 (headphones+mic).

Since Fedora 10 I lost the headphones and I have not checked the mic.
Comment 11 Walter Neumann 2009-01-06 11:11:09 EST
Confirming on Dell Precision M4400:

Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Reverting to kernel 2.6.27.7-134 makes headphones work.
Comment 12 August Schwerdfeger 2009-01-09 03:01:58 EST
Confirming on Dell Inspiron 1420N:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Headphones work on kernel 2.6.27.7-134 but not 2.6.27.9-159.
Comment 13 Kyrre Ness Sjøbæk 2009-01-09 18:57:47 EST
Confirming on Dell Latitude D520.

Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

Sound generally works, but plugging something into the headphone jack mutes speakers without enabling the jack. Unpluging unmutes speakers again.
Comment 14 Kyrre Ness Sjøbæk 2009-01-09 19:10:20 EST
I can also confirmed it worked on Fedora 7 and 9.

Running kernel:
uname -a
Linux sinus 2.6.27.9-159.fc10.x86_64 #1 SMP Tue Dec 16 14:47:52 EST 2008 x86_64 x86_64 x86_64 GNU/Linux


I must say: This is actually the first bug i've hit with F10, running for ~1½ weeks on two machines (laptop + desktop) + installed a friends laptop. Suspend now works perfectly, and everything else is also ticking along very nicely. Nice job, thanks a lot for a great OS! I have ran (almost) every fedora/redhat since RH9 + RHEL4/5 + CentOS 4, and this is the best experience so far. Keep it up!
Comment 15 bashaarman 2009-01-10 09:11:43 EST
Confirming on Dell Inspiron 6400

Audio device: 82801G (ICH7 Family) High Definition Audio Controller

Headphones work on kernel 2.6.27.7-134 but not 2.6.27.10-169
Comment 16 Askar Ali Khan 2009-01-11 05:05:37 EST
Same here sound from headphone not working but from speakers working fine. I am running Fedora 9 on Dell Latitude D630 before kernel 2.6.27.9-73.fc9.i686 sound from headphone was working fine.

cat /proc/asound/cards 
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe9fc000 irq 21

I'll revert back no problem but wonders what has been changed that stopped headphone working in new kernel?
Comment 17 Enygma 2009-01-11 11:02:53 EST
It's a bit annoying when things like this happen. Updates should be incremental in the way that if in version X something is working, after adding something in version X+1, that same thing *must still* be working.

It's not really an update if you lose functionality, now is it?

Things like these give a bad reputation to updating and make you thing twice before doing an automatic update. If you are updating crucial stuff, you might end up losing lots of time to make it work again.

This is a Quality Assurance problem that I think should be invested in inside the Fedora project.

I really like the Redhat++/Fedora distribution and I hate to hear bad comments about it, mainly because it's very that stable.

Besides all this, keep doing a great job guys!

Best of luck!
Comment 18 J Gallagher 2009-01-12 14:23:40 EST
On a Dell Inspiron 1520 with SigmaTel STAC9205,  headphone sound works in 2.6.27.7-134.fc10.x86_64 but on none of the later releases including 2.6.27.10-169.fc10.x86_64 in rawhide.

The changelog for 2.6.27.10-169.fc10 states there is "hopefully" a fix for this (headphones on Dell laptops), so I guess the "hopefully" part was quite literal.
Comment 19 bashaarman 2009-01-18 09:58:32 EST
Headphone sound works correctly again with kernel-2.6.28.1-9.rc2.fc10
Comment 20 robert 2009-01-22 10:47:47 EST
On Dell Latitude D830 same problem with kernel 2.6.27.9-159.fc10.i686.PAE. No sound on front speakers and headphones, after pluging headset jack and unpluging sound appears on front speakers. The other way is to put the system to Hiberante and back it also brings the sound.

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Problem is fixed with kernel 2.6.28.1-19.fc10.i686.PAE. Unfortunately I need ndiswrapper for that version and some other things so staying with 2.6.27.9-159.fc10.i686.PAE.
Comment 21 Walter Neumann 2009-01-27 09:28:13 EST
This is fixed for me with kernel 2.6.27.12-170.2.5.fc10.x86_64
Comment 22 robert 2009-01-27 10:50:22 EST
On Dell Latitude D830 this is fixed with kernel 2.6.27.12-170.2.5.fc10.i686.PAE.
Thank you guys, great work.
Comment 23 August Schwerdfeger 2009-01-27 11:32:04 EST
On Dell Inspiron 1420N, fixed with kernel 2.6.27.12-170.2.5.fc10.x86_64.
Comment 24 Kyrre Ness Sjøbæk 2009-01-27 13:57:59 EST
Dell Latitude D520, 2.6.27.12-170.2.5.fc10.x86_64, fixed.
Comment 25 Enygma 2009-01-27 16:10:29 EST
Fixed on Dell Inspiron 1520 as well!

Now we have to wait for yum to get the nvidia drivers for this kernel. :| But this is not the first time this is happening :)

Anyway, great work guys!

Thank you!
Comment 26 bood.junk 2009-01-27 17:34:32 EST
Issue resolve in Fedora 9 on Dell Latitude D620 with Kernel:

2.6.27.12-78.2.8.fc9.i686
Comment 27 David M. Lloyd 2009-01-27 17:50:57 EST
Fixed for me in Fedora 9, Dell Precision 490

2.6.27.12-78.2.8.fc9.x86_64

00:1b.0 Audio device [0403]: Intel Corporation 631xESB/632xESB High Definition Audio Controller [8086:269a] (rev 09)

Thanks!
Comment 28 Askar Ali Khan 2009-01-28 00:23:56 EST
Fixed for me in Fedora 9, Dell Latitude D630

After upgraded kernel to 2.6.27.12-78.2.8.fc9.i686

Thanks.
Comment 29 Yaakov Nemoy 2009-01-30 00:00:46 EST
Works for me on 2.6.27.12-170.2.5.fc10.x86_64 .
Comment 30 Alexander 2009-01-31 00:31:33 EST
Here, with 2.6.27.12-170.2.5.fc10.i686 and SigmaTel STAC9228, all is well too.
Both outputs are fixed.
Comment 31 Everaldo Bernardo Cunha 2011-11-14 17:10:47 EST
I can't hear my headfone in the Fedora 16 “Verne”, but the normal sound execute. I don't know what's happening in my Operation System. The commands following was give with the intantion of show which is the sound kind, see:


[everaldo@dual ~]$ uname -a
Linux dual 3.1.1-1.fc16.i686.PAE #1 SMP Fri Nov 11 22:04:40 UTC 2011 i686 i686 i386 GNU/Linux
[everaldo@dual ~]$ lspci -v | grep -i AUDIO
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
[everaldo@dual ~]$ 


Wait you can help me in solution of this problem ...
Comment 32 Andre Costa 2011-11-15 07:46:01 EST
Hi,

if your audio chipset is from Realtek, this page helped me activate sound on front headphone jack on both F15 and F16: https://bbs.archlinux.org/viewtopic.php?id=117574

You can find latest hda-verb source code on the internet, but anyway I am attaching the version I used.

One last word of advice: F16 doesn't ship with /etc/rc.local by default, I had to create it on /etc/rc.d and make a symlink to /etc. Also, this file has to be executable (chmod +x) and has to start with "#!/bin/bash". Make sure you use the absolute path to where you installed hda-verb.

Hope this helps.
Comment 33 Andre Costa 2011-11-15 07:47:25 EST
Created attachment 533757 [details]
hda-verb utility source code
Comment 34 Everaldo Bernardo Cunha 2011-11-15 22:04:46 EST
(In reply to comment #32)
> Hi,
> 
> if your audio chipset is from Realtek, this page helped me activate sound on
> front headphone jack on both F15 and F16:
> https://bbs.archlinux.org/viewtopic.php?id=117574
> 
> You can find latest hda-verb source code on the internet, but anyway I am
> attaching the version I used.
> 
> One last word of advice: F16 doesn't ship with /etc/rc.local by default, I had
> to create it on /etc/rc.d and make a symlink to /etc. Also, this file has to be
> executable (chmod +x) and has to start with "#!/bin/bash". Make sure you use
> the absolute path to where you installed hda-verb.
> 
> Hope this helps.

My friend,

What do I wrong? See my file "sound" in /etc/rc.d and the symlink to /etc/rc5.d/, see in the file created:

#!/bin/bash



/etc/rc.d/./hda-verb /dev/snd/hwC0D2 0x15 SET_CONNECT_SEL 0x08

arecord -vvv /dev/null
arecord -D default -vvv /dev/null
arecord -D default:0 -vvv /dev/null

pcm.!default plughw


What gave I making now? The solution not work ... and now?
Comment 35 Andre Costa 2011-11-19 16:53:54 EST
Everaldo, I guess you got the info on that page wrong.

The init script doesn't have to have anything other the "hda-verb" execution, it should be simply

#!/bin/bash

<path>/hda-verb /dev/snd/hwC0D2 0x15 SET_CONNECT_SEL 0x08

where <path> points to where you installed had-verb (judging by your script, you put it on /etc/rc.d ; not sure if it's the best location, maybe /usr/local/bin would be a better choice). Also, notice that the script must be executable.

The "pcm.!default plughw", if necessary, should go into /etc/asound.conf.

I guess the simplest way to see if it will work for you is run by hand the "hda-verb" command with the parameters above (you need to do it as root).
Comment 36 Everaldo Bernardo Cunha 2011-11-26 04:56:11 EST
(In reply to comment #35)
> Everaldo, I guess you got the info on that page wrong.
> 
> The init script doesn't have to have anything other the "hda-verb" execution,
> it should be simply
> 
> #!/bin/bash
> 
> <path>/hda-verb /dev/snd/hwC0D2 0x15 SET_CONNECT_SEL 0x08
> 
> where <path> points to where you installed had-verb (judging by your script,
> you put it on /etc/rc.d ; not sure if it's the best location, maybe
> /usr/local/bin would be a better choice). Also, notice that the script must be
> executable.
> 
> The "pcm.!default plughw", if necessary, should go into /etc/asound.conf.
> 
> I guess the simplest way to see if it will work for you is run by hand the
> "hda-verb" command with the parameters above (you need to do it as root).

Friend, I don't get to undertand the help. Below, I'm putting what is showing in the konsole of Fedora 16:

[everaldo@dual hda-verb-0.3]$ sudo hda-verb /dev/snd/hwC0D2 0x15 0x08 SET_CONNECT_SEL
sudo: hda-verb: command not found
[everaldo@dual hda-verb-0.3]$ sudo ./hda-verb /dev/snd/hwC0D2 0x15 0x08 SET_CONNECT_SEL
open: No such file or directory
[everaldo@dual hda-verb-0.3]$ ls -la /dev/snd/
total 0
drwxr-xr-x.  4 root root      320 Nov 26 07:06 .
drwxr-xr-x. 20 root root     3640 Nov 26 07:06 ..
drwxr-xr-x.  2 root root       60 Nov 26 07:06 by-id
drwxr-xr-x.  2 root root      100 Nov 26 07:06 by-path
crw-rw----+  1 root audio 116,  3 Nov 26 07:06 controlC0
crw-rw----+  1 root audio 116,  5 Nov 26 07:06 controlC1
crw-rw----+  1 root audio 116, 11 Nov 26 07:06 controlC2
crw-rw----+  1 root audio 116, 10 Nov 26 07:06 hwC2D0
crw-rw----+  1 root audio 116,  2 Nov 26 07:06 pcmC0D0c
crw-rw----+  1 root audio 116,  4 Nov 26 07:06 pcmC1D0c
crw-rw----+  1 root audio 116,  9 Nov 26 07:06 pcmC2D0c
crw-rw----+  1 root audio 116,  8 Nov 26 07:15 pcmC2D0p
crw-rw----+  1 root audio 116,  7 Nov 26 07:06 pcmC2D1p
crw-rw----+  1 root audio 116,  6 Nov 26 07:06 pcmC2D2p
crw-rw----+  1 root audio 116,  1 Nov 26 07:06 seq
crw-rw----+  1 root audio 116, 33 Nov 26 07:06 timer
[everaldo@dual hda-verb-0.3]$ sudo ./hda-verb /dev/snd/hwC2D0 0x15 0x08 SET_CONNECT_SEL
No key matching with 'SET_CONNECT_SEL'
[everaldo@dual hda-verb-0.3]$ sudo ./hda-verb -h
usage: hda-verb hwdep-device nid verb param
known verbs:
  GET_STREAM_FORMAT, GET_AMP_GAIN_MUTE, GET_PROC_COEF, GET_COEF_INDEX
  PARAMETERS, GET_CONNECT_SEL, GET_CONNECT_LIST, GET_PROC_STATE
  GET_SDI_SELECT, GET_POWER_STATE, GET_CONV, GET_PIN_WIDGET_CONTROL
  GET_UNSOLICITED_RESPONSE, GET_PIN_SENSE, GET_BEEP_CONTROL
  GET_EAPD_BTLENABLE, GET_DIGI_CONVERT_1, GET_DIGI_CONVERT_2
  GET_VOLUME_KNOB_CONTROL, GET_GPIO_DATA, GET_GPIO_MASK
  GET_GPIO_DIRECTION, GET_GPIO_WAKE_MASK, GET_GPIO_UNSOLICITED_RSP_MASK
  GET_GPIO_STICKY_MASK, GET_CONFIG_DEFAULT, GET_SUBSYSTEM_ID
  SET_STREAM_FORMAT, SET_AMP_GAIN_MUTE, SET_PROC_COEF, SET_COEF_INDEX
  SET_CONNECT_SEL, SET_PROC_STATE, SET_SDI_SELECT, SET_POWER_STATE
  SET_CHANNEL_STREAMID, SET_PIN_WIDGET_CONTROL, SET_UNSOLICITED_ENABLE
  SET_PIN_SENSE, SET_BEEP_CONTROL, SET_EAPD_BTLENABLE, SET_DIGI_CONVERT_1
  SET_DIGI_CONVERT_2, SET_VOLUME_KNOB_CONTROL, SET_GPIO_DATA
  SET_GPIO_MASK, SET_GPIO_DIRECTION, SET_GPIO_WAKE_MASK
  SET_GPIO_UNSOLICITED_RSP_MASK, SET_GPIO_STICKY_MASK
  SET_CONFIG_DEFAULT_BYTES_0, SET_CONFIG_DEFAULT_BYTES_1
  SET_CONFIG_DEFAULT_BYTES_2, SET_CONFIG_DEFAULT_BYTES_3, SET_CODEC_RESET
known parameters:
  VENDOR_ID, SUBSYSTEM_ID, REV_ID, NODE_COUNT, FUNCTION_TYPE
  AUDIO_FG_CAP, AUDIO_WIDGET_CAP, PCM, STREAM, PIN_CAP, AMP_IN_CAP
  CONNLIST_LEN, POWER_STATE, PROC_CAP, GPIO_CAP, AMP_OUT_CAP
  VOL_KNB_CAP
[everaldo@dual hda-verb-0.3]$ 
----------

How must I proced in this case???
Comment 37 Andre Costa 2011-11-26 19:24:11 EST
(In reply to comment #36)
> Friend, I don't get to undertand the help. Below, I'm putting what is showing
> in the konsole of Fedora 16:
> 
> [everaldo@dual hda-verb-0.3]$ sudo hda-verb /dev/snd/hwC0D2 0x15 0x08
> SET_CONNECT_SEL
> sudo: hda-verb: command not found
> [everaldo@dual hda-verb-0.3]$ sudo ./hda-verb /dev/snd/hwC0D2 0x15 0x08
> SET_CONNECT_SEL
> open: No such file or directory
> [everaldo@dual hda-verb-0.3]$ ls -la /dev/snd/
> total 0
> drwxr-xr-x.  4 root root      320 Nov 26 07:06 .
> drwxr-xr-x. 20 root root     3640 Nov 26 07:06 ..
> drwxr-xr-x.  2 root root       60 Nov 26 07:06 by-id
> drwxr-xr-x.  2 root root      100 Nov 26 07:06 by-path
> crw-rw----+  1 root audio 116,  3 Nov 26 07:06 controlC0
> crw-rw----+  1 root audio 116,  5 Nov 26 07:06 controlC1
> crw-rw----+  1 root audio 116, 11 Nov 26 07:06 controlC2
> crw-rw----+  1 root audio 116, 10 Nov 26 07:06 hwC2D0
> crw-rw----+  1 root audio 116,  2 Nov 26 07:06 pcmC0D0c
> crw-rw----+  1 root audio 116,  4 Nov 26 07:06 pcmC1D0c
> crw-rw----+  1 root audio 116,  9 Nov 26 07:06 pcmC2D0c
> crw-rw----+  1 root audio 116,  8 Nov 26 07:15 pcmC2D0p
> crw-rw----+  1 root audio 116,  7 Nov 26 07:06 pcmC2D1p
> crw-rw----+  1 root audio 116,  6 Nov 26 07:06 pcmC2D2p
> crw-rw----+  1 root audio 116,  1 Nov 26 07:06 seq
> crw-rw----+  1 root audio 116, 33 Nov 26 07:06 timer
> [everaldo@dual hda-verb-0.3]$ sudo ./hda-verb /dev/snd/hwC2D0 0x15 0x08
> SET_CONNECT_SEL
> No key matching with 'SET_CONNECT_SEL'
[snip]
> ----------
> 
> How must I proced in this case???

You're passing the parameters in the wrong order. 0x08 must be passed *after* SET_CONNECT_SEL, not before.

Anyway, it seems you have /dev/snd/hwC2D0 instead of /dev/snd/hwC0D2 (the device mentioned on the Arch Linux forum), so I'm not sure it will work for you. But, it's worth a try.

Note You need to log in before you can comment on or make changes to this bug.