Bug 472338 - emacs crashes
emacs crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 01:08 EST by Ian Lance Taylor
Modified: 2013-01-09 23:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 11:12:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Lance Taylor 2008-11-20 01:08:03 EST
Description of problem:

I'm running Fedora 9 on a Lenovo Thinkpad T43P.  I've seen emacs crash four times in the last three weeks.  It seems to happen when running GNUS and fetching e-mail over IMAP, although that may not have anything to do with it.  It just happened again this evening.  I saw this in my .xsession-errors file:

Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x3cc767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0x3cc90e]
#2 /usr/lib/libX11.so.6 [0x4311109]
#3 /usr/lib/libX11.so.6(XCreatePixmap+0x26) [0x42e6d06]
#4 /usr/lib/libgdk-x11-2.0.so.0(gdk_pixmap_new+0x21f) [0x4b42ed6]
#5 /usr/lib/libgdk-x11-2.0.so.0(gdk_window_begin_paint_region+0x1f5) [0x4b19b41]
#6 /usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x23a) [0x484557d]
#7 /usr/lib/libgdk-x11-2.0.so.0 [0x4b1d0bd]
#8 /usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0xcc) [0x4b1d218]
#9 emacs [0x80cc9f2]
#10 emacs [0x80ccaa7]
#11 emacs [0x80cd105]
#12 emacs [0x80cd173]
#13 /usr/lib/libX11.so.6(_XError+0x109) [0x4309a49]
#14 /usr/lib/libX11.so.6 [0x4311ac8]
#15 /usr/lib/libX11.so.6(_XEventsQueued+0x55) [0x4312435]
#16 /usr/lib/libX11.so.6(XPending+0x68) [0x42fa428]
#17 /usr/lib/libgdk-x11-2.0.so.0 [0x4b328db]
#18 /usr/lib/libgdk-x11-2.0.so.0 [0x4b35e6e]
#19 /lib/libglib-2.0.so.0(g_main_context_prepare+0x1c2) [0x18ed42]
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x3cc767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0x3cc90e]
#2 /usr/lib/libX11.so.6 [0x4311109]
#3 /usr/lib/libX11.so.6(XFlush+0x29) [0x42e9b39]
#4 /usr/lib/libgdk-x11-2.0.so.0(gdk_display_flush+0xa0) [0x4b26384]
#5 /usr/lib/libgdk-x11-2.0.so.0 [0x4b1d12c]
#6 /usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0xf8) [0x4b1d244]
#7 emacs [0x80cc9f2]
#8 emacs [0x80ccaa7]
#9 emacs [0x80cd105]
#10 emacs [0x80cd173]
#11 /usr/lib/libX11.so.6(_XError+0x109) [0x4309a49]
#12 /usr/lib/libX11.so.6 [0x4311ac8]
#13 /usr/lib/libX11.so.6(_XEventsQueued+0x55) [0x4312435]
#14 /usr/lib/libX11.so.6(_XFlush+0x42) [0x43124c2]
#15 /usr/lib/libX11.so.6(XFlush+0x31) [0x42e9b41]
#16 /usr/lib/libgdk-x11-2.0.so.0(gdk_display_flush+0xa0) [0x4b26384]
#17 /usr/lib/libgdk-x11-2.0.so.0 [0x4b1d12c]
#18 /usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0xf8) [0x4b1d244]
#19 emacs [0x80cc9f2]
X protocol error: BadValue (integer parameter out of range for operation) on protocol request 77


Version-Release number of selected component (if applicable):

emacs-22.2-5.fc9.i386
gtk2-devel-2.12.12-1.fc9.i386
libX11-1.1.4-1.fc9.i386
libxcb-1.1-5.fc9.i386

How reproducible:

Run emacs.  I start it from a button on the panel.  Run GNUS.  Fetch e-mail over IMAP and see if emacs crashes.  This is very intermittent, and it works most of the time.  It seems to fail more often shortly after a reboot.
Comment 1 Jon Dufresne 2009-03-16 10:34:11 EDT
Thank you for taking the time to report this bug. This bug report isn't very
useful because it is incomplete. You'll need to add a full stack trace; please make sure you have debuginfo packages installed and see http://fedoraproject.org/wiki/StackTraces for more information about getting a useful stack trace.
Thank you.
Comment 2 Ian Lance Taylor 2009-03-16 11:12:30 EDT
I've upgraded to FC10 and the bug no longer occurs.  So I'll close it.

Note You need to log in before you can comment on or make changes to this bug.