Bug 472368 - Systems can't register on Satellite 5.2 because rhel-instnum is not installed by default
Systems can't register on Satellite 5.2 because rhel-instnum is not installed...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
medium Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Jeff Browning
: EasyFix
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-11-20 09:42 EST by Rafael Godínez Pérez
Modified: 2010-10-23 02:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Godínez Pérez 2008-11-20 09:42:00 EST
Description of problem:
RHN clients can't register on Satellite right after clean Satellite installation and channel sync.

Version-Release number of selected component (if applicable):
5.2.0

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 5.2 @Base on server
2. Install RHN Satellite 5.2 on server
3. Populate RHEL 5 channels
4. Try to register any RHEL 5 client.
  
Actual results:
System is not registered in Satellite.

Following error is displayed in client.

[root@localhost ~]# rhnreg_ks -vvv --username=admin --password=****
An error has occurred:
While running 'registration.welcome_message': caught
exceptions.KeyError : 'xmlrpc'

Error communicating with server. The message was:
While running 'registration.welcome_message': caught
exceptions.KeyError : 'xmlrpc'

See /var/log/up2date for more information
[root@localhost ~]# 

In satellite,
# cat /var/log/rhn/rhn_server_xmlrpc.log

(...): server/rhnImport.load('ERROR', 'Error importing xmlrpc: No module named instnum')
(...): rhnSQL/int_oracle.connect('Connecting to database', 'rhnsat')


Expected results:
Succesful registration in Satellite.


Additional info:
Problem is that rhel-instnum is not resolved as dependency by satellite installer, and therefore is not installed by default.

To fix this manually, in satellite:
# yum install rhel-instnum
and restart satellite services

And from then on, clients register properly.
Comment 1 Jan Pazdziora 2008-11-20 10:35:17 EST
Are you sure you've installed @base? Because I can see

      <packagereq type="mandatory">rhel-instnum</packagereq>

in

        <group>
          <id>base</id>

So the rhel-instnum should be there after RHEL 5.2 @base installation.
Comment 2 Rafael Godínez Pérez 2008-11-20 10:59:12 EST
Well, reviewing my diary,  I've actually done a graphical interactive installation of RHEL 5.1, select Minimal (doesn't it match @base? ), and after installation and registration in RHN, I made a live update to current version (5.2+).

What I found after the error and analyzing the logs, is that rhel-instnum was not there.
I did yum install rhel-instnum, and it downloaded from RHN and installed rhel-instnum-1.0.8-1.el5-noarch .

Maybe it is a bug with RHEL 5.1 installation image, but anyway Satellite installer should check for this dependency as it does for other packages not anymore included with RHNS 5.2 and also not present in @Base.
Comment 3 Jan Pazdziora 2008-11-20 11:10:38 EST
I don't think Minimal is @base. Minimal is @core. You can do

   yum groupinstall @base

and see if you have everything in place.

I'd therefore consider this user error, not meeting Software Requirements.

We should probably Require that rhel-instnum from some of our packages anyway, so I'm aligning this to 5.3.0, but I do not see this as 5.2.1 issue.
Comment 4 Rafael Godínez Pérez 2008-11-20 11:56:32 EST
    OK, I'm surprised to know Minimal is @base. Good to know.
    From seeing the @base definition you wrote before, after minimal install, I'm
    pretty sure "yum groupinstall @base" will work.

    How difficult could be to include dependency checking for rhel-instnum in
    5.2.1?
    Or, maybe, some Release note regarding this.
Comment 5 Brandon Perkins 2008-11-20 13:13:25 EST
Agreed.  And Cliff and I think that one of the rhns xmlrpc packages should have a requires on rhel-instnum as the fix here.
Comment 6 Jan Pazdziora 2008-12-12 09:44:27 EST
Fix committed to upstream (Spacewalk), tracked in bug 476212.
Comment 7 Jan Pazdziora 2008-12-25 12:03:52 EST
With Satellite-5.3.0-RHEL5-re20081223.1 and Satellite-5.3.0-RHEL4-re20081223.2 composes available, moving ON_QA.
Comment 8 Jeff Browning 2009-02-16 18:00:29 EST
rhel-instnum is installed in a clean Sat 530 install to @base.

RHEL5 system registered to the 530 Sat without error.

Verified.
Comment 10 wes hayutin 2009-08-05 15:43:13 EDT
[root@dhcp77-153 Spacewalk]# rpm -q rhel-instnum
rhel-instnum-1.0.9-1.el5

release pending
Comment 11 Brandon Perkins 2009-09-10 16:30:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.