Bug 472372 - ath9k kernel issue
ath9k kernel issue
Status: CLOSED DUPLICATE of bug 470225
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 09:56 EST by Juta Sirakas
Modified: 2008-11-20 10:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 10:58:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juta Sirakas 2008-11-20 09:56:14 EST
Description of problem:
Nov 20 15:41:29 nokkel NetworkManager: <info>  DHCP: device ath0 state changed preinit -> bound
Nov 20 15:41:29 nokkel NetworkManager: <info>  Activation (ath0) Stage 4 of 5 (IP Configure Get) scheduled...
Nov 20 15:41:29 nokkel NetworkManager: <info>  Activation (ath0) Stage 4 of 5 (IP Configure Get) started...
Nov 20 15:41:29 nokkel NetworkManager: <info>    address 172.16.22.227
Nov 20 15:41:29 nokkel NetworkManager: <info>    prefix 24 (255.255.255.0)
Nov 20 15:41:29 nokkel NetworkManager: <info>    gateway 172.16.22.254
Nov 20 15:41:29 nokkel NetworkManager: <info>    nameserver '172.16.18.50'
Nov 20 15:41:29 nokkel NetworkManager: <info>    nameserver '172.16.18.51'
Nov 20 15:41:29 nokkel NetworkManager: <info>    domain name 'office.skype.net'
Nov 20 15:41:29 nokkel NetworkManager: <info>  Activation (ath0) Stage 5 of 5 (IP Configure Commit) scheduled...
Nov 20 15:41:29 nokkel NetworkManager: <info>  Activation (ath0) Stage 4 of 5 (IP Configure Get) complete.
Nov 20 15:41:29 nokkel NetworkManager: <info>  Activation (ath0) Stage 5 of 5 (IP Configure Commit) started...
Nov 20 15:41:29 nokkel dhclient: bound to 172.16.22.227 -- renewal in 173697 seconds.
Nov 20 15:41:30 nokkel NetworkManager: <info>  (ath0): device state change: 7 -> 8
Nov 20 15:41:30 nokkel NetworkManager: <info>  Policy set (ath0) as default device for routing and DNS.
Nov 20 15:41:30 nokkel NetworkManager: <info>  Activation (ath0) successful, device activated.
Nov 20 15:41:30 nokkel NetworkManager: <info>  Activation (ath0) Stage 5 of 5 (IP Configure Commit) complete.
Nov 20 15:41:30 nokkel nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/05-netfs' exited with error status 1.
Nov 20 15:41:46 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 7 -> 0
Nov 20 15:41:46 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 0 -> 2
Nov 20 15:41:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 2 -> 4
Nov 20 15:41:50 nokkel kernel: ------------[ cut here ]------------
Nov 20 15:41:50 nokkel kernel: WARNING: at include/../net/mac80211/rate.h:152 ath_get_rate+0xf0/0x397 [ath9k]() (Not tainted)
Nov 20 15:41:50 nokkel kernel: Modules linked in: sit tunnel4 ipv6 i2c_dev aes_x86_64 aes_generic nls_utf8 hfsplus fuse radeon drm applesmc input_polldev ppdev parport coretemp hwmon rfcomm l2cap bluetooth cpufreq_ondemand acpi_cpufreq freq_table dm_multipath scsi_dh snd_hda_intel arc4 snd_seq_dummy ecb snd_seq_oss snd_seq_midi_event snd_seq uvcvideo compat_ioctl32 firewire_ohci crypto_blkcipher videodev snd_seq_device firewire_core snd_pcm_oss ac v4l1_compat ath9k snd_mixer_oss video output joydev sr_mod appletouch snd_pcm battery cdrom snd_timer iTCO_wdt iTCO_vendor_support snd_page_alloc pcspkr snd_hwdep i2c_i801 sky2 snd soundcore isight_firmware crc_itu_t mac80211 cfg80211 i2c_core sg dm_snapshot dm_zero dm_mirror dm_log dm_mod ata_generic pata_acpi ata_piix libata sd_mod scsi_mod crc_t10dif ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: vmnet]
Nov 20 15:41:50 nokkel kernel: Pid: 1508, comm: ath9k Not tainted 2.6.27.5-37.fc9.x86_64 #1
Nov 20 15:41:50 nokkel kernel:
Nov 20 15:41:50 nokkel kernel: Call Trace:
Nov 20 15:41:50 nokkel kernel: [<ffffffff8103fdd0>] warn_on_slowpath+0x60/0x8e
Nov 20 15:41:50 nokkel kernel: [<ffffffffa01f24f9>] ? ath9k_hw_set_txpower+0x17cc/0x18c4 [ath9k]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa020262d>] ath_get_rate+0xf0/0x397 [ath9k]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa0119059>] rate_control_get_rate+0x82/0xfc [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa011e070>] invoke_tx_handlers+0x33c/0xa8c [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa011da0b>] ? __ieee80211_tx_prepare+0x2a2/0x2ef [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa011fb64>] ieee80211_master_start_xmit+0x226/0x3ba [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffff81241d02>] dev_hard_start_xmit+0x1d6/0x258
Nov 20 15:41:50 nokkel kernel: [<ffffffff812539c7>] __qdisc_run+0xed/0x206
Nov 20 15:41:50 nokkel kernel: [<ffffffff81010a07>] ? restore_args+0x0/0x30
Nov 20 15:41:50 nokkel kernel: [<ffffffff8123ffe3>] qdisc_run+0x36/0x3b
Nov 20 15:41:50 nokkel kernel: [<ffffffff812421d5>] dev_queue_xmit+0x344/0x453
Nov 20 15:41:50 nokkel kernel: [<ffffffffa01147ad>] ieee80211_sta_tx+0x6f/0x74 [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa011498b>] ieee80211_send_nullfunc+0xd9/0xe6 [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffff81044ede>] ? _local_bh_enable_ip+0xd5/0xe2
Nov 20 15:41:50 nokkel kernel: [<ffffffffa011542c>] ieee80211_scan_completed+0x225/0x2d5 [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa0115783>] ieee80211_sta_scan_work+0xaf/0x1a9 [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffffa01156d4>] ? ieee80211_sta_scan_work+0x0/0x1a9 [mac80211]
Nov 20 15:41:50 nokkel kernel: [<ffffffff8104fdf9>] run_workqueue+0xa3/0x146
Nov 20 15:41:50 nokkel kernel: [<ffffffff8104ff91>] worker_thread+0xf5/0x109
Nov 20 15:41:50 nokkel kernel: [<ffffffff810536f5>] ? autoremove_wake_function+0x0/0x38
Nov 20 15:41:50 nokkel kernel: [<ffffffff8104fe9c>] ? worker_thread+0x0/0x109
Nov 20 15:41:50 nokkel kernel: [<ffffffff8105338b>] kthread+0x49/0x76
Nov 20 15:41:50 nokkel kernel: [<ffffffff810116e9>] child_rip+0xa/0x11
Nov 20 15:41:50 nokkel kernel: [<ffffffff81010a07>] ? restore_args+0x0/0x30
Nov 20 15:41:50 nokkel kernel: [<ffffffff81053342>] ? kthread+0x0/0x76
Nov 20 15:41:50 nokkel kernel: [<ffffffff810116df>] ? child_rip+0x0/0x11
Nov 20 15:41:50 nokkel kernel:
Nov 20 15:41:50 nokkel kernel: ---[ end trace 1c80a25ea4656acf ]---
Nov 20 15:41:50 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 4 -> 3
Nov 20 15:41:52 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 3 -> 4
Nov 20 15:41:52 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 4 -> 5
Nov 20 15:41:52 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 5 -> 6
Nov 20 15:41:52 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 6 -> 7
Nov 20 15:53:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 7 -> 6
Nov 20 15:53:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 6 -> 7
Nov 20 16:08:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 7 -> 6
Nov 20 16:08:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 6 -> 7
Nov 20 16:23:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 7 -> 6
Nov 20 16:23:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 6 -> 7
Nov 20 16:24:17 nokkel kernel: ACPI: EC: non-query interrupt received, switching to interrupt mode
Nov 20 16:24:19 nokkel kernel: ACPI: EC: non-query interrupt received, switching to interrupt mode
Nov 20 16:38:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 7 -> 6
Nov 20 16:38:47 nokkel NetworkManager: <info>  (ath0): supplicant connection state change: 6 -> 7
Nov 20 16:45:16 nokkel kernel: ACPI: EC: non-query interrupt received, switching to interrupt mode


Version-Release number of selected component (if applicable):
kernel-2.6.27.5-37.fc9.x86_64

Additional info:
is suspend somehow related? after wakeup from suspend, wifi continues to work.
Comment 1 John W. Linville 2008-11-20 10:58:31 EST

*** This bug has been marked as a duplicate of bug 470225 ***

Note You need to log in before you can comment on or make changes to this bug.