Bug 47238 - Bad "Device" section in anaconda-generate XF86Config
Bad "Device" section in anaconda-generate XF86Config
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-03 21:05 EDT by Sam Varshavchik
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 15:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bad XF86Config that came out of the installer. (16.35 KB, text/plain)
2001-07-03 21:06 EDT, Sam Varshavchik
no flags Details
Fixed XF86Config (16.35 KB, text/plain)
2001-07-03 21:07 EDT, Sam Varshavchik
no flags Details
lspci output. (2.85 KB, text/plain)
2001-07-03 21:08 EDT, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2001-07-03 21:05:42 EDT
Did a text-mode install.  The XF86Config generated by anaconda has a
completely bogus Device section that doesn't even match the Screen section.
 The screen section specifies a device "Chips & Technologies CT65550",
while the device section specifies a "Chips & Technologies CT65520".
Obviously, this is not going to work very well...

I'm attaching both the original and the fixed XF86Config file.  All I had
to do is change the name to "CT65550", in order to get X working.  I
actually had to make two other fixes in XF86Config.  I had to adjust
HorizSync, which is probably borked as a result of the wrong stuff going
into the Device section.  I also had to fix the default depth+resolution. 
That was always broken for this particular video card, it's a known issue.
 The main deal is the mismatch between the two sections, which pretty much
puts a stop to the show.
Comment 1 Sam Varshavchik 2001-07-03 21:06:19 EDT
Created attachment 22627 [details]
Bad XF86Config that came out of the installer.
Comment 2 Sam Varshavchik 2001-07-03 21:07:38 EDT
Created attachment 22628 [details]
Fixed XF86Config
Comment 3 Sam Varshavchik 2001-07-03 21:08:35 EDT
Created attachment 22629 [details]
lspci output.
Comment 4 Sam Varshavchik 2001-07-03 21:09:13 EDT
I should also add that running Xconfigurator generates a perfectly valid XF86Config.

Comment 5 Glen Foster 2001-07-13 15:45:57 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 6 Michael Fulbright 2001-07-19 21:40:03 EDT
The problem is the CT65550 is one of about a dozen cards the have multiple 'SEE'
 references in the Cards definition. The anaconda code was just taking the last
reference in the linked list, which in this case was the CT65520. I've changed
the code to properly merge all the members of the list.

Beta 3 will contain this fix, please let me know if it does not correct the problem.

Note You need to log in before you can comment on or make changes to this bug.