Bug 472430 - LOCKD_*PORT in /etc/sysconfig/nfs ignored while booting (sysctl key unknown)
LOCKD_*PORT in /etc/sysconfig/nfs ignored while booting (sysctl key unknown)
Status: CLOSED DUPLICATE of bug 474449
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Dickson
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 14:41 EST by Leon Fauster
Modified: 2009-06-08 10:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 15:32:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Fauster 2008-11-20 14:41:50 EST
Description of problem:
LOCKD_*PORT settings in /etc/sysconfig/nfs are ignored while booting the system.

Afterwards it can be triggered by 
 /etc/init.d/nfs* restart 
and this time there are readed.

speak - settings are ignored onetime / while booting
 

Version-Release number of selected component (if applicable):
1.0.9-35z.el5_2

How reproducible:
every boot time

Steps to Reproduce:
1. Set LOCKD_*PORT in sysconfig/nfs 
2. ReBoot 
3. confirm with rpcinfo -p
  
Actual results:
random ports for lockd

Expected results:
specified port for lockd

Additional info:
workaround: set 
 options lockd nlm_*port=xxxxx
for modprobe
Comment 2 Steve Dickson 2009-04-24 15:32:21 EDT
This will be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=474449
Meaning loading the nfsd module will make sysctl variables exist
when the they are being set.

*** This bug has been marked as a duplicate of bug 474449 ***

Note You need to log in before you can comment on or make changes to this bug.