Bug 472439 - Crash in libexempi when viewing certain image's EXIV properties
Crash in libexempi when viewing certain image's EXIV properties
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: exempi (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 15:29 EST by James
Modified: 2009-01-23 21:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-23 21:35:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exiv data that upsets Nautilus (8.29 KB, application/octet-stream)
2008-11-20 15:29 EST, James
no flags Details
gdb session provoking the crash (6.66 KB, text/plain)
2008-12-31 10:01 EST, James
no flags Details
Example image that crashes nautilus (10.04 KB, image/jpeg)
2008-12-31 10:04 EST, James
no flags Details
More detailed gdb transcript (6.16 KB, text/plain)
2008-12-31 10:15 EST, James
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 566141 None None None Never

  None (edit)
Description James 2008-11-20 15:29:24 EST
Created attachment 324231 [details]
Exiv data that upsets Nautilus

Description of problem:
Attempting to view the properties sheet of JPEG image files created with a Kodak EasyShare CD43 camera causes nautilus to restart. In fact, it seems to be the exiv data that's the trouble: extracting it with exiv2 and inserting it into any other JPEG image also provokes the problem. An example .exv file is attached.

Note that exiftool and exiv2 behave OK with these images.

Version-Release number of selected component (if applicable):
nautilus-2.22.5.1-1.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Insert attached exiv data into a JPEG using exiv2.
2. Attempt to view its properties sheet.
  
Actual results:
Nautilus restarts. Can't find any evidence of a core dump.

Expected results:
Properties sheet.
Comment 1 James 2008-11-28 16:00:26 EST
nautilus-2.24.1-3.fc10.i386 is not affected by this issue, so it would be nice to see the fix backported.
Comment 2 James 2008-12-23 20:19:17 EST
This has shown up in nautilus-2.24.2-1.fc10.x86_64. Make the following file as exiv2.txt:

# exiv2 -m exiv2.txt *.JPG
set Exif.Image.Make              "Pentax"
set Exif.Image.Model             "Pentax P30N"
set Exif.Image.Orientation       0
set Exif.Image.XResolution       600/1
set Exif.Image.YResolution       600/1
set Exif.Image.ResolutionUnit    1
set Exif.Photo.ExposureProgram   1
set Exif.Photo.ISOSpeedRatings   400
set Exif.Photo.ExposureBiasValue 0/3
set Exif.Photo.Flash             1

and apply it to a JPEG using

    exiv2 -m exiv2.txt mypicture.jpeg

For me, JPEGs thus treated cause nautilus to restart when viewing their properties (although it's not always 100% reproducible and I don't know what precise set of tags triggers it).
Comment 3 James 2008-12-31 10:01:39 EST
Created attachment 328013 [details]
gdb session provoking the crash

I've found out it's a segfault in libexempi. The attached gdb log contains a backtrace. I've also attached below the image blank-crasher.jpeg I crafted to get this fault.
Comment 4 James 2008-12-31 10:04:15 EST
Created attachment 328014 [details]
Example image that crashes nautilus
Comment 5 James 2008-12-31 10:15:11 EST
Created attachment 328015 [details]
More detailed gdb transcript
Comment 6 James 2009-01-02 14:54:10 EST
I can confirm that this is, in fact, an exempi bug. So far, I don't see the problem when using the upstream exempi 2.1.0, built by dropping the original sources into the SRPM for exempi 2.0.1.
Comment 7 Fedora Update System 2009-01-06 14:23:37 EST
exempi-2.1.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/exempi-2.1.0-1.fc10
Comment 8 Fedora Update System 2009-01-07 16:51:47 EST
exempi-2.1.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update exempi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0251
Comment 9 Fedora Update System 2009-01-23 21:35:10 EST
exempi-2.1.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.