Bug 472442 - NetworkManager-glib-devel BuildRequires breaks s390x
NetworkManager-glib-devel BuildRequires breaks s390x
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
Reported: 2008-11-20 15:49 EST by Brad Hinson
Modified: 2009-02-16 11:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-16 11:12:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brad Hinson 2008-11-20 15:49:00 EST
Description of problem:
Currently NetworkManager has ExcludeArch s390x, which means as-is, PackageKit doesn't build, due to PackageKit BuildRequires NetworkManager-glib-devel.

On s390x, rpmbuild without NetworkManager-glib-devel installed (forced with --nodeps) builds successfully.  Can we add "%ifnarch s390 s390x" around this BuildRequires?

Version-Release number of selected component (if applicable):
Comment 1 Richard Hughes 2008-11-21 06:02:25 EST
Is the NetworkManager build failure on s390x fixable? I would rather get NM fixed on s390x rather than cut the PK dependency chain. If NM is 100% unbuildable on s390x (which seems odd to me) then I guess we can ifdef the dep.
Comment 2 Bug Zapper 2008-11-26 00:42:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:

Note You need to log in before you can comment on or make changes to this bug.