Bug 472495 - ath9k ath_pci module fails with "software IOTLB in use, aborting"
ath9k ath_pci module fails with "software IOTLB in use, aborting"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 00:43 EST by Patrick Walton
Modified: 2008-12-04 11:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 11:26:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Walton 2008-11-21 00:43:46 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

Today my ath9k wifi chipset on my Asus M50VM laptop is no longer detected by any network components. Instead I get the following in my dmesg:

ath9k: 0.1
ath_pci: software IOTLB in use, aborting

Since the release of Fedora 10 is so close, this seems to me to be a major bug.


Reproducible: Always
Comment 1 John W. Linville 2008-11-21 10:22:00 EST
Not as major as the disk corruption it is meant to avoid... :-)

FWIW, there are now patches upstream for fixing that issue.  So maybe F10's anti-ath9k hack can disappear before too long.  Unfortunately, I think release procedures are such that it is too late to get those patches into F10's default install kernel.

I didn't put that hack in, but I suppose I'll grab this bug and make sure the hack disappears once the appropriate patches are available in Fedora kernels.
Comment 2 Chuck Ebbert 2008-11-22 01:43:22 EST
(In reply to comment #2)
> 
> Today my ath9k wifi chipset on my Asus M50VM laptop is no longer detected by
> any network components. Instead I get the following in my dmesg:
> 

Do you have 4GB of memory or more installed?
Comment 3 Patrick Walton 2008-11-22 01:47:20 EST
Yes, this x86_64-based laptop has 4 GB of memory.
Comment 4 Chuck Ebbert 2008-11-24 16:09:34 EST
(In reply to comment #3)
> Yes, this x86_64-based laptop has 4 GB of memory.

You can work around this problem by adding "mem=3G" to the kernel boot options in grub.conf (on the line that starts with "kernel")
Comment 5 Bug Zapper 2008-11-26 00:42:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 John W. Linville 2008-12-03 09:39:20 EST
The test kernels here have patches intended to address this issue:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=72916

Please give them a try and post the results here...thanks!
Comment 7 Pieter-Jan Busschaert 2008-12-03 12:38:55 EST
I have the same problem and tried to test that kernel-2.6.27.7-135.fc10, however, there was a dependency problem with the kernel-firmware package. I searched for kernel-firmware-2.6.27.7-135.fc10, but couldn't find it anywhere.
Comment 8 John W. Linville 2008-12-03 13:15:44 EST
You may want to look closer -- that package is available under the "noarch" part of the RPMs... :-)
Comment 9 Patrick Walton 2008-12-03 17:21:22 EST
Works for me, thanks!

Note You need to log in before you can comment on or make changes to this bug.