Bug 472517 - Fast double-click to select word followed by a right click to get context menu seems to use previous context
Fast double-click to select word followed by a right click to get context men...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 08:01 EST by Caolan McNamara
Modified: 2009-03-19 09:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 09:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2008-11-21 08:01:44 EST
Description of problem:
I get the wrong spelling suggestions sometimes, suggestions from another incorrect spelt word that I've recently visited. Does affect e.g. gedit or openoffice.org or firefox or xchat.

Version-Release number of selected component (if applicable):
evolution-2.24.1-2.fc10.i386

How reproducible:
100% for me

Steps to Reproduce:
(UK/Ireland dictionaries in this case)

Into the message composer type
wrongA incorrectB
both should be underlined as incorrect, right click on incorrectB and get a suggestion like "correctable", don't correct it. Right click on wrongB and get a suggestion like sarong, don't correct it. Fast double-click on incorrectB followed quickly and follow with a right-click and get "sarong" etc as suggestions, i.e. the ones from wrongA. Click inside incorrectB to deselect it and now right click and get the "correctable" suggestion.

Other variants include getting no spelling suggestions sometimes, and instead a delete table entry, probably depending on where the cursor was before the double-click
Comment 1 Caolan McNamara 2008-11-21 08:03:07 EST
"I get the wrong spelling suggestions sometimes", sigh, you wouldn't know that I'm (nominally at least) a native English speaker
Comment 2 Matthew Barnes 2008-11-21 08:26:16 EST
Heh.  Confirmed.  I'll check this out.
Comment 3 Matthew Barnes 2008-11-21 09:17:15 EST
Changing component, since I can also reproduce this on the test editor program that ships with GtkHtml.
Comment 4 Matthew Barnes 2008-11-21 09:38:07 EST
Think I found the problem.

The context menu is only refreshing itself if you're _not_ right-clicking in a selection.  The right answer is to always refresh, selection or not.

Furthermore, and this is arguable, but the original intent was to _not_ display spelling suggestions if you're right-clicking in a selection.  It's sufficient to just right-click on the word without highlighting it.

We should probably check whether the selection contains only a single word and display suggestions in that case, but I'll have to deal with that separately.  With the fix I'm applying here you should at least get consistent results now.
Comment 5 Matthew Barnes 2008-11-21 11:17:02 EST
I've fixed this upstream.  There's a new release scheduled for Monday so I won't bother with a patch.  I'll close this when Evolution 2.24.2 is packaged.
Comment 6 Bug Zapper 2008-11-26 00:43:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Caolan McNamara 2009-03-19 09:37:46 EDT
Closing, works great in F-10 for ages

Note You need to log in before you can comment on or make changes to this bug.