Bug 472553 - Error Message: "tar: <path_to_file>: Warning: Cannot acl_from_text: Invalid argument" when extracting from tar-archive.
Error Message: "tar: <path_to_file>: Warning: Cannot acl_from_text: Invalid a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tar (Show other bugs)
5.2
All All
medium Severity high
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 13:03 EST by Ondrej Vasik
Modified: 2010-10-23 02:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:19:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Vasik 2008-11-21 13:03:39 EST
+++ This bug was initially created as a clone of Bug #472355 +++

Description of problem:

* I do not know how the communication between different linux distributions
  about bugs works.
  I have posted the above error to CentOS, and if it is an error, its your error
  too.

* For error details see therefore the following link:
  "http://bugs.centos.org/view.php?id=3254"

Version-Release number of selected component (if applicable):
tar-1.15.1-24.el5 (Reporter used "tar-1.15.1-23.0.1.el5", but error still exists in latest rhel-5 version)

How to reproduce:

1. creating e.g. a tar-archive by
   "tar -cf test.tar --directory=/usr/share/icons --acls --xattrs . "
   * "--acls" is it seems to be mandatory for the error.
2. extracting the tar archive by "tar -xf test.tar"
   --> the error (see Summary) occurs on many but not all files of the archive.

Notes:
There are few off-by-one issues in RHEL-5 tar xattrs patch, making it very unpredictable and possibly not working correctly for ACL's. Problem solved in Fedora Rawhide tar-1.20-5.fc11 .
Comment 1 RHEL Product and Program Management 2009-03-26 12:54:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 10 errata-xmlrpc 2010-03-30 04:19:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0224.html

Note You need to log in before you can comment on or make changes to this bug.