This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472580 - clones aren't populating the fixed_in feild.
clones aren't populating the fixed_in feild.
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: XINSUN
:
Depends On: 192443
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 16:03 EST by Rob Landry
Modified: 2008-12-18 10:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 10:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Landry 2008-11-21 16:03:37 EST
Description of problem:

As the summary says, clones with fixed_in fields used will show the corrected data but then don't actually save it to the db, it looks like the field on the template isn't filled in which causes this.
Comment 1 XINSUN 2008-12-01 05:00:55 EST
This is cause by below codes:

=========================================================================

[% IF isduplicate %]
    [% IF bug.dup_info.cf_fixed_in != bug.cf_fixed_in %]
       <s>[% bug.cf_fixed_in FILTER html %]</s> [% bug.dup_info.cf_fixed_in FILTER html %]
       <br>(saving changes will save corrected version)
       [%# Cludgy; but to change the default for cf_fixed_in is is rh_edit.html.tmpl #%]

==========================================================================

From above codes: seems that cf_fixed_in will be saved by filling the correct value in the cf_fixed_in by hand.


This bug is blocked by bug #192443.
Comment 2 Rob Landry 2008-12-03 14:11:37 EST
I believe the issue is that the rh_edit.html.tmpl isn't automatically filling in the field; from looking it seems the rh_edit template is still counting on the errata tool access which doesn't exist any more.  Instead the template should just use the parents cf_fixed_in field.

Likely however this whole issue should go away when 192443 is sorted as I expect the correct solution there is to provide only drop downs for version and no longer use the fixed_in field but we'll see.
Comment 3 XINSUN 2008-12-18 10:08:58 EST
cf_fixed_in will be not used by catalog any more and it will be removed in the patch of bug #192443. so we can close this bug.

Note You need to log in before you can comment on or make changes to this bug.