Bug 472581 - Kernel panic during hibernate on Tyan S2881
Kernel panic during hibernate on Tyan S2881
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 16:05 EST by Orion Poplawski
Modified: 2013-01-10 02:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 06:23:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from S2881 system (18.30 KB, text/plain)
2009-02-18 12:26 EST, Orion Poplawski
no flags Details
dmesg from S2882 system (17.14 KB, text/plain)
2009-02-18 12:30 EST, Orion Poplawski
no flags Details
Don't save aperture memory (1.34 KB, patch)
2009-02-18 12:37 EST, Matthew Garrett
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2008-11-21 16:05:17 EST
Description of problem:

Going into hibernate on Tyan S2881 based system panics running 2.6.18-92.1.18.el5.

Hand copied:

Process: bash
Trace:
swsusp_arch_suspend+0x7c/0x80
swsusp_suspend+0x2c/0x51
pm_suspend_disk+0x42/0xce
enter_state+0x5e/0x19b
state_store+0x5e/0x79
sysfs_write_file+0xb9/0xe8
vfs_write+0x45/0x6e
tracesys+0xd5/0xe0

Code: 48 8b 04 11 48 89 04 16 48 83 c2 08 48 81 fa 00 10 00 00 75
RIP: swsusp_save+0x27a/0x335
RSP: <ffff81017861de10>
CR2: <ffff81000c000000>

Kernel panic - not syncing: Fatal exception

Tried to capture with serial console, but all I get is:

Disabling non-boot CPUs ...
Breaking affinity for irq 4
CPU 1 is now offline
CPU1 is down
Stopping tasks: ==============================================================================================|
Shrinking memory... done (60097 pages freed)
 usbdev2.1_ep81: PM: suspend 0->1, parent 2-0:1.0 already 1
 usbdev1.1_ep81: PM: suspend 0->1, parent 1-0:1.0 already 1
Comment 1 Matthew Garrett 2009-02-16 19:38:23 EST
Could you attach the full dmesg for this system? Does booting with the

iommu=soft

kernel commandline argument avoid the oops?
Comment 2 Matthew Garrett 2009-02-16 19:41:09 EST
Also, is it possible to test 5.3 on this system? A bug was fixed that would lead to failed hibernation on amd64 systems with 4GB or more of RAM.
Comment 3 Orion Poplawski 2009-02-18 12:26:18 EST
Created attachment 332422 [details]
dmesg from S2881 system

iommu=soft does appear to prevent the crash, however it appears to disable wake on lan as well.  Or maybe wake on lan has never worked from hibernate and I just haven't been able to do it before.  wake on lan from power off works.

5.3 will have to wait for a bit, but we will be moving to it soon.
Comment 4 Orion Poplawski 2009-02-18 12:30:36 EST
Created attachment 332423 [details]
dmesg from S2882 system

Also seeing on S2882 system.  Have crash dumps as well.
Comment 5 Matthew Garrett 2009-02-18 12:37:29 EST
Created attachment 332426 [details]
Don't save aperture memory

The bug is caused by the system attempting to save and restore the contents of the iommu aperture. This patch should fix the problem and has been integrated into the 5.3 release.
Comment 6 Orion Poplawski 2009-02-18 13:31:02 EST
I've installed the 2.6.18-128.1.1 kernel and indeed hibernate is now working.  Thanks!

I am having trouble with wake on lan though.  When I powerdown the NIC is left running (NIC light on the machine is on).  When I use hibernate, the NIC is turned off.  Does the kernel have any control over this, or is this a BIOS only thing?
Comment 7 Matthew Garrett 2009-02-18 13:38:28 EST
Wake on LAN sounds like #476501. Could you subscribe to that bug and provide the information requested there?
Comment 8 Orion Poplawski 2009-02-18 13:49:44 EST
Will do.  Feel free to close this bug.

Note You need to log in before you can comment on or make changes to this bug.