Bug 472631 - Needs libgcrypt >= 1.4.3
Needs libgcrypt >= 1.4.3
Product: Fedora
Classification: Fedora
Component: gnutls (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2008-11-21 23:58 EST by Braden McDaniel
Modified: 2008-11-22 17:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-22 15:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2008-11-21 23:58:58 EST
Description of problem:
Trying to run gnutls-2.4.2-2.fc10 with libgcypt-1.4.0-3 results in a runtime error like this:

svn: relocation error: /usr/lib64/libgnutls.so.26: symbol gcry_cipher_setkey, version GCRYPT_1.2 not defined in file libgcrypt.so.11 with link time reference

Updating to libgcrypt-1.4.2-2.fc10 resolves the problem.

Version-Release number of selected component (if applicable):
Comment 1 Tomas Mraz 2008-11-22 11:26:44 EST
But we have libgcrypt-1.4.3 in Fedora 10 prereleases and Rawhide. So I don't understand what is the problem.
Comment 2 Braden McDaniel 2008-11-22 13:32:06 EST
The problem is that this sort of relationship is exactly what dependencies are for.  Maintaining correct dependencies maintains the correctness of the spec file and the resiliency of the package.  It ensures that updates that may not fall neatly into the categories you've envisioned can still succeed.

What exactly is the argument against reflecting this dependency in the spec file?
Comment 3 Tomas Mraz 2008-11-22 15:13:54 EST
Unfortunately this would have to be fixed by moving the gcry_cipher_setkey to a new symbol version. We cannot do that. And hardcoding the dependency on libgcrypt >=1.4.2 would not be correct either.
Comment 4 Braden McDaniel 2008-11-22 15:41:35 EST
Pardon my ignorance, but why wouldn't "Requires: libgcrypt >= 1.4.2" be correct?
Comment 5 Tomas Mraz 2008-11-22 15:46:32 EST
Because if you compile it against libgcrypt-1.4.0 or whatever it will compile OK and not require libgcrypt >= 1.4.2 (the gcry_cipher_setkey() was changed from macro to function in libgcrypt-1.4.2).
Comment 6 Braden McDaniel 2008-11-22 17:58:31 EST
Then couple it with BuildRequires: libgrypt-devel >= 1.4.2.

It may be ugly, but it's less ugly than simply having this dependency go undocumented and unenforced.

Note You need to log in before you can comment on or make changes to this bug.