Bug 472637 - libpng.so: cannot open shared object file: No such file or directo
libpng.so: cannot open shared object file: No such file or directo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2008-11-22 06:00 EST by Nicolas Mailhot
Modified: 2008-12-16 18:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 18:19:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-11-22 06:00:07 EST
Description of problem:

Starting fontforge from the CLI results in

$ fontforge DroidSans.ttf 
Copyright (c) 2000-2008 by George Williams.
 Executable based on sources from 02:38 GMT 27-Sep-2008.
 Library based on sources from 15:05 GMT 25-Sep-2008.
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
libpng.so: cannot open shared object file: No such file or directory
…
Comment 1 Kevin Fenzi 2008-11-22 16:05:44 EST
Which fontforge version? 
This looks like a newer one than rawhide?

output of: 

rpm -q libpng 

rpm -V libpng 

And where can I find the DroidSans.ttf ?
Comment 2 Nicolas Mailhot 2008-11-22 16:13:58 EST
$ rpm -q libpng 
libpng-2:1.2.31-2.fc10.x86_64
$ rpm -V libpng 
$ rpm -q fontforge
fontforge-20080927-1.fc11.x86_64
$ rpm -V fontforge

In F11 rawhide
http://koji.fedoraproject.org/koji/buildinfo?buildID=68830

http://android.git.kernel.org/?p=platform/frameworks/base.git;a=tree;f=data/fonts
Comment 3 Bug Zapper 2008-11-26 00:47:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jon Stanley 2008-11-26 14:13:44 EST
Fixing version to align with rawhide again.  Sorry for the noise.
Comment 5 Kevin Fenzi 2008-12-02 02:14:21 EST
Can you try http://koji.fedoraproject.org/koji/taskinfo?taskID=970252 ?
Comment 6 Kevin Fenzi 2008-12-16 18:19:49 EST
The 20081215 version I just built in rawhide should have this corrected. 

Closing this now. Feel free to reopen this or file a new one if you spot anything.

Note You need to log in before you can comment on or make changes to this bug.