Bug 472674 - Don't (try to) use intel driver for GMA500 graphics card
Don't (try to) use intel driver for GMA500 graphics card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-23 05:38 EST by Jurgen Kramer
Modified: 2009-02-10 10:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 10:40:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (7.78 KB, application/octet-stream)
2008-11-24 12:41 EST, Jurgen Kramer
no flags Details
Xorg.1.log (7.78 KB, application/octet-stream)
2008-11-24 12:41 EST, Jurgen Kramer
no flags Details
Xorg.2.log (7.78 KB, text/plain)
2008-11-24 12:42 EST, Jurgen Kramer
no flags Details
Xorg.3.log (7.78 KB, text/plain)
2008-11-24 12:42 EST, Jurgen Kramer
no flags Details
Xorg.4.log (7.78 KB, application/octet-stream)
2008-11-24 12:43 EST, Jurgen Kramer
no flags Details
Xorg.5.log (7.78 KB, text/plain)
2008-11-24 12:43 EST, Jurgen Kramer
no flags Details
output of manual Xorg -probe -verbose 5 cmd (13.58 KB, text/plain)
2008-11-24 12:44 EST, Jurgen Kramer
no flags Details
output from dmesg (33.68 KB, text/plain)
2008-11-24 12:44 EST, Jurgen Kramer
no flags Details
lspci output (1.31 KB, text/plain)
2008-11-24 12:45 EST, Jurgen Kramer
no flags Details
lsusb output (973 bytes, text/plain)
2008-11-24 12:46 EST, Jurgen Kramer
no flags Details

  None (edit)
Description Jurgen Kramer 2008-11-23 05:38:55 EST
Description of problem:
When booting the current F10 preview i386 live CD it tries to load the intel X driver which fails because it does not support the GMA500 hw

Version-Release number of selected component (if applicable):
F10 Preview i686 live

How reproducible:
Always

Steps to Reproduce:
1. Boot from live CD 
2. X does not come up
3.
  
Actual results:
X does not come up, leaves system waiting with blinking cursor

Expected results:
System uses a proper GMA500 (poulsbo) driver or VESA

Additional info:
This is on a Asus R50A UMPC, Intel Atom Z520 CPU and GMA500 (poulsbo) graphics.
Comment 1 Matěj Cepl 2008-11-24 04:38:13 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jurgen Kramer 2008-11-24 12:39:40 EST
I've attached the requested files.
Xorg.?.log are logs generated from a normal bootup. xprobe.txt is generated by me issuing a Xorg -probe -verbose 5 command. dmesg/lspci en lsusb output thrown in for good measure. xorg.conf is missing because it was not there (running from the live F10 preview CD).
Further details can be provided if needed.
Comment 3 Jurgen Kramer 2008-11-24 12:41:02 EST
Created attachment 324512 [details]
Xorg.0.log

Xorg.0.log autogenerated from normal bootup
Comment 4 Jurgen Kramer 2008-11-24 12:41:30 EST
Created attachment 324513 [details]
Xorg.1.log

Xorg.1.log autogenerated from normal bootup
Comment 5 Jurgen Kramer 2008-11-24 12:42:17 EST
Created attachment 324514 [details]
Xorg.2.log

Xorg.2.log autogenerated from normal bootup
Comment 6 Jurgen Kramer 2008-11-24 12:42:48 EST
Created attachment 324515 [details]
Xorg.3.log

Xorg.3.log autogenerated from normal bootup
Comment 7 Jurgen Kramer 2008-11-24 12:43:15 EST
Created attachment 324516 [details]
Xorg.4.log

Xorg.4.log autogenerated from normal bootup
Comment 8 Jurgen Kramer 2008-11-24 12:43:41 EST
Created attachment 324517 [details]
Xorg.5.log

Xorg.5.log autogenerated from normal bootup
Comment 9 Jurgen Kramer 2008-11-24 12:44:17 EST
Created attachment 324518 [details]
output of manual Xorg -probe -verbose 5 cmd

output of manual Xorg -probe -verbose 5 cmd
Comment 10 Jurgen Kramer 2008-11-24 12:44:48 EST
Created attachment 324519 [details]
output from dmesg

dmesg output
Comment 11 Jurgen Kramer 2008-11-24 12:45:24 EST
Created attachment 324520 [details]
lspci output

lspci output
Comment 12 Jurgen Kramer 2008-11-24 12:46:16 EST
Created attachment 324521 [details]
lsusb output

lsusb output
Comment 13 Bug Zapper 2008-11-26 00:48:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bill Phipps 2009-01-08 10:12:44 EST
I have the same experience on F10.  However, I can get the vesa framebuffer mode to work only if I add a vga= line to the boot cmdline.  I only have an 800x600 flat panel for devel, so I add vga=0x315.  Graphical boot including animated plymouth and Xorg now work fine.  I did try variants of nomodeset and modprobing vesafb to no avail.  It seems the BIOS needs to set the chipset into VESA mode first and then it works.  I can help test any patches if necessary.  Using Atom Z530 with US15W chipset with GMA500.
Comment 15 Frank Ch. Eigler 2009-01-11 11:14:51 EST
The xorg-driver-psb driver from the intel moblin trees would solve this
problem, were it finished and merged into xorg.  vesa works only to the
extent that the video bios includes mode descriptions for the physical
screens, which in several UMPC's cases it doesn't.
Comment 16 Adam Jackson 2009-02-10 10:40:42 EST
1.5.99.902-7 will fall back to vesa for poulsbo now.  This isn't great, but the psb driver isn't upstream and I don't know of anybody willing to own maintenance of it at the moment.

Note You need to log in before you can comment on or make changes to this bug.